Jump to content
General Bug Report Guidelines - Please Read ×

Strict Nat Problem, I Did Exactly What Warframe Told Me To, But I'm Still Recieving Strict Nat Messages


zavienh5
 Share

Recommended Posts

     UPDATED: I solved it!  No Strict NAT, all systems Nominal.  I will update with info how to solve it once my dad explains it.  all I know is that my dad restarted/ resetted the wifi machine(mine is AT&T U-verse).

 

 

 

Old Post:

      So this Strict NAT thing has been going on for like 2 months now, and my laptop used to be able to handle my Warframe on max settings, now I have to turn everything off in settings and turn the resolution on the lowest and it still lags with terrifying frame drops.  Everyday the connection gets worse and worse. And I swear, that I opened up separate ports for each Warframe on each computer in my house.  Even my dad, a engineer who designed a lot of electronics and knows how to fix every household and computer bugs for 35 years of experience, he can't figure out why my Warframe has this problem and it's really p*ssing me off.

 

My AT&T Uverse does not support UPnP, also a lot of wifi machines do not too because it's too dangerous since people can hack and steal people's wifi connection.

 

Can anyone help me please, I provided proof down below that I did what Warframe directed me to do.

idjNC1H.jpg

8aaWpns.png

I'm the only person playing Warframe in my family, I have multiple Warframes installed because sometimes my parents need to borrow my computer and I have to use the slow ones.

Edited by zavienh5
Link to comment
Share on other sites

I have the same problem. Port forwarding, setting up a dynamic IP address, nothing worked. :( I've just lived with it. It sucks though.

well then follow my topic, hopefully someone will explain why the hell this is happening

Link to comment
Share on other sites

Maybe there's folks steeling yo wifi?

 

I don't know how to fix your problem. But I do know that Warframe has quiete the issues when it comes to matchmaking. It could be the game and not you.

my dads a very experienced engineer, he locked up access for our wifi from other people in the cyberspace and set firewalls up

Link to comment
Share on other sites

well then follow my topic, hopefully someone will explain why the hell this is happening

I've come to the conclusion that it probably has to do with me living in rural Kansas, and only having one local company even be able to reach my house. Even though we get good speed, I would have to guess that I can't change my NAT because of my provider. 

Link to comment
Share on other sites

If you're running WF twice on the same network it tends to say that. Like if i play on my ps4 and pc at the same time, the second one i try to use has that pop up

I'm the only person playing Warframe in my family, I have multiple Warframes installed because sometimes my parents need to borrow my computer and I have to use the slow ones.

Link to comment
Share on other sites

This is what my friend did. Ingame you can change ports in settings from the current one to another by clicking the right arrow once. Save, restart game, and presto

didnt work and my dad was like wtf, course it wont work lol

Edited by zavienh5
Link to comment
Share on other sites

OP, IDK where you are in this world but I have the same provider, router page and everything as you. I also experience the same issue. I have years of experience in hosting game servers from home, I never had any issues with ports until I switched from DSL to AT&T Uverse. For some god forsaken reason, I can only have open ports on one (1) computer in my house at any given time. I have tested this and found it to be true to my own set up.

 

I really wish I could help you, but even AT&T left me out in the cold. I contacted their support, was bounced between 3 to 5 people and never got an answer. They eventually forwarded me to a support service that I had to pay for to access, which I wasn't willing to do.

 

I'll follow this thread though, I plan on contacting AT&T again tomorrow regarding my home internet / phone service, maybe I'll see if I can resolve the issue. Don't stress yourself over it, it just wont work any easy way to my knowledge. Forward your ports for the one machine you play the most on and if you have to, but can access the router page from the other computers, change it up. It will save the configuration for the ports, you just need to apply it to whatever machine and restart the router.

Link to comment
Share on other sites

@genthis Thanks a lot mate! Its all working now ! Yay! (After a few months of solo playing, I can finally play with guildies xD)

Link to comment
Share on other sites

Some ISPs (such as AT&T) enforce Type 3 NAT on all of their devices. It's really a nasty thing to do.

 

In the meanwhile, enable UPnP. No one is going to "steal your wifi" with it, and it only makes sense to turn it off if you're working in a high security environment where computers on the network contain things like classified information or corporate secrets. Additionally, the only real UPnP threat comes from outside of your network (it comes from the WAN, the Wide-Area-Network, a.k.a. the rest of the internet). Many routers' firmware are updates to block external UPnP requests, so this is no longer an issue. If you're worried about it, turn on UPnP and then run the Rapid7 UPnP Vulnerability Check to see if your router is vulnerable. Chances are you'll get a "Congratulations! Your router did not respond to a UPnP discovery request" message, which means you're all good.

 

 

 

tl;dr Turn on UPnP, you're not at risk with it on and leaving it off is like wearing a hazmat suit to avoid potential springtime allergies. Some ISPs enforce Type-3 NAT (Strict) on their hardware, in which case you're out of luck and should definitely switch ISPs or get different hardware to connect with. You can also try DMZ-ing the computer you want to use to play; assuming it's an actual DMZ then your computer would be Type-1 NAT (Directly connected to the net), which is open/loose and you shouldn't get the issue. If you DMZ your computer and still get the error, you're out of luck. Also make sure all the IPs on your network are manually assigned if you're going to DMZ or use port forwarding.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...