Jump to content
General Bug Report Guidelines - Please Read ×

Game Freezes In The Launcher And Can't Update


Recommended Posts

Okay, this happened to me after the 13.9.1 hotfix,


First i can't download the update, everytime i tried it starts downloading but the download speed reduces to 0b/s, i mean, if i'm downloading at 1,5mb/s it will get to 0,5mb/s and after to 5,b/s and doesn't download anything.


After several tries, the game updated, i logged in and everything worked fine, then, i get out and started to play again, but the launcher stopped at "Checking for updates..." and never get through this point.


I veryfied the game files on Steam, and it started to redownload all the game, again.


Anyone else having this problem?

Edited by A71U
Link to comment
Share on other sites

i'm having issues with the launcher too, but mine says the content server is unavailable.

so mine wont even update.


if it is downloaded through steam apparently you can verify the download cache and it'll start working. (im checking if this works right now for my problem.)

Edited by Evdokiya.Infernalis
Link to comment
Share on other sites

I get that too, 3 times, the launcher doesn't download the game and after that said that some thing of the update couldn't be downloaded and restarted the update process.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...