Jump to content

Vors Prize Glitch


Recommended Posts

this is a warning to players before the do Vors Prize.

try your best to not do anything out of order "example" building the item Davro gives you once you activate the foundry will not allow you to continue the quest line. also if you exit the game while in mission (or game crash) it will also render the  quest inoperable so you will forever be stuck on that part of the quest until DE fixes it. I currently know of no workaround for it so if you know of one let people know ^_^.

              things I've tried to get eh quest line to work

1) re-logging will work for some things  (like getting an item if you were in a group)

2) re-launching the game doesn't seem to work for me

3) I even tried a fresh install an it didn't work

so if you have tried something that I have not and it worked please let people know thank you ^_^

Edited by Shadowwolves32
Link to comment
Share on other sites

I'm with the first 3, my quest thing is screwed. I did that corpus mission with 3 crates, but when i got back to the Cephalon, nothing happened. No messages, cutscenes, and I couldn't add the part(s) i had found. I'm stuck with nothing to do.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...