Jump to content
General Bug Report Guidelines - Please Read ×

Mod Insert Bug


Recommended Posts

I recently built an Orokin Catalyst mod and put it on my rank 30 Furax.

Problem is I cannot put one mod in particular on.

I could put this mod on before I applied the catalyst mod.

Every time I attempt to insert an Organ Shatter Mod (4 of 5 rank) onto my Furax the game stops responding.

I can back out of the mod editor but the overlay for the the mods stays on my screen even when I back out all the way to the log in screen.

I've rebooted my client several times and even tried to reapply this mod on a different pc.

Still no luck! Anyone else having this issue? :c If so, do we know fixes?! Id like my crit dmg back. lol


Link to comment
Share on other sites

I have a similar issue


I was upgrading a piercing hit mod, pulled it off my gorgon, but my gorgon seems to think it's still installed, even tho it's in my avail mod list. When i check my mod inventory it is not there, but is in the avail list and when I try to put it on the weapon, the weapon mod overlay freezes on my screen

Link to comment
Share on other sites

Bumpity, bump bump bump.


Same issue.  I currently have a Rank 18 Excalibur, supercharged with an Orokin Reactor.  It doesn't show that I have Slash Dash installed, which I know I do; I use it frequently against certain heavies.  I have five other that show up, adding up to 30 (two with reduced cost) and the bar above shows that I can fit four more, so I would assume my installed Slash Dash is at 4, then reduced to 2 (thus 32 out of my current 36 capacity).


I see another Slash Dash in my inventory that shows up at a cost of 2.  Even just moving this causes my Warframe client to get stuck with the Mod overlay, even when I log out of the game, forcing me to exit and restart so I can see stuff.  As far as I can tell, this one mod is what throws me off.  I can move around my installed mods just fine, although I cannot see Slash Dash up there.


Should I open a support ticket instead with the pair of screen shots I snagged and the other info the help desk asks for?

Link to comment
Share on other sites

Well, i got another one. I want to use the "Dual heat swords" but i am unable to put that "charge speed mod" into it.. the bug is rly nasty, cos besides that i cant use that mod, the mod UI framework stays on my screen even when i push the "back" button.. if so, there is nothing i can do anymore other than making a relog.


ps without that mod the "DHS" are pretty useless. So three times #*($%%@ in a row.


Gl champs!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...