Jump to content

Archived

This topic is now archived and is closed to further replies.

Zardlon

Nova Antimatter Drop Damage Absorption Bugged?

Recommended Posts

Nova's Antimatter Drop "Creates a volatile orb of antimatter which is steered with the aiming-reticle after being created. This particle absorbs all damage (friendly and hostile) when shot at, and once contacting a solid object it will detonate for 100 base damage + 100% / 200% / 300% / 400% of all absorbed damage as 18px-Radiation_b.png Radiation damage with an explosion radius of 5 / 8 / 10 / 15 meters."

 

Depending on how well your weapon is modded, firing at the orb would cause the ability to cause a great deal of damage to surrounding enemies. Since Update 14 this ability seems to sometimes not follow it's discription of absorbing any incoming damage, let alone multiplying it either. I'm not sure if this is necessarily a bug or something implemented in the game as a cap for the damage absorption.

 

In some cases firing my Boltor Prime in a short burst would be enough for the Orb to do it's job, but I've noticed when dumping the entire magazine into the Orb it will have little to no affect when it comes to absorbing damage. Leaving me to deal the base of 100 damage on swarms of incoming enemies. You could see how this could be a problem for Nova players, as they have little health and shield to begin with and relying on an ability that (sometimes) doesn't work at the worst situations.

 

I want to hear if anyone else is having the same problem as I and if so could there be a fix for it?

Share this post


Link to post
Share on other sites

Just want to agree with and give this a bump.  AMD no longer absorbs my attacks, and detonates for base damage only.

Share this post


Link to post
Share on other sites

I have also had this issue when running Nova.  Her antimatter drop no longer seems to absorb weapon damage, and explodes for the minimum amount each time.

Share this post


Link to post
Share on other sites

I believe this is a host vs client bug. Your Nova's AMD doesn't work when you're a client.

Share this post


Link to post
Share on other sites

also not getting a cool-down on Mol prime as a Client, which is annoying for timing it, and lets you spam..

Share this post


Link to post
Share on other sites

I have posted this in so many threads.. Still not on the damned megathreads... 

Share this post


Link to post
Share on other sites

I feel u, yes got different result when ur hosting or be client...i red many thread and the wiki too, this bug was long time unsolved issue.
Well i supposed temporary solved problem that u should be the one that hosting for Nova OP equiped. Hope DE fixed it soon

Share this post


Link to post
Share on other sites

×
×
  • Create New...