Jump to content

Not Receiving Pickups Or Mission Rewards.


Recommended Posts

Twice in two days I've done a mission and not received any reward for it, the first time I did an Alert for an Oberon head and upon completion I received every reward but the Oberon head and the alert was no longer listed on the solar system as if I had completed. Today I did several Solar Rail Sabotage missions trying to get the Decisive Judgement mod, managed to pick it up and Rage in a match finally only to not receive it as well in the end (even though this time it actually showed them among the obtained mods for that mission).

Link to post
Share on other sites

Its nice to know I wasnt the only one with this issue. I was on Malva Venus and found a decisive judgment and a berserker mod with a succesful mission only to find that they werent in my inventory after the match.

Link to post
Share on other sites

I put in a support ticket yesterday for the Oberon head, but seeing it happen again today makes me think it's a bug so I updated my support ticket and posted this here. Hopefully this gets resolved as it took me days of farming to get that damn Decisive Judgement mod and I don't want to start all over again.

Link to post
Share on other sites

It's been about five days now I believe since I put a support ticket in for this and still haven't heard back about it. DE Support has always been pretty quick about responding to support tickets, so I'm starting to think I'm just going to miss out on these rewards. In the time I've waited I could have probably got another drop for Decisive Judgement, but I really don't like Dark Sectors the way they are now. I hope they get back to me soon about this...

Edited by Severanth
Link to post
Share on other sites

So DS is pretty much eating every single mod that drops in it, I don't know if this is just me but I haven't received a single mod that dropped in there. So far I've had Berserker drop a few times, Rage drop once, Decisive Judgement drop once, and Flow drop quite a few times. Every single time I've had any of these mods drop, none of them have been added to my mod inventory. This is getting to the point of infuriating and making me want to quit this game. I contacted support last week, still haven't heard back from them. I don't like to come on the forums and rage, but seriously this is getting ridiculous.

Link to post
Share on other sites

This has happened to me three times today, all three times it was during void survival, 25+ minutes each time gone to waste and it is getting mighty tiresome.

Ofcourse my keys are used up but no rewards.

Sorry, but two hours of trying to get prime stuff and other mods that are not utter rubbish into the toilet. YAY!

Link to post
Share on other sites

I'm on day five now with no response from DE to my support ticket. It's frustrating because I've seen in other posts where people have said they contacted support and got a response back right away. I submitted my ticket with screenshots, and details as to what planet, node, and time it all happened and it's still taking this long to get a response. The fact that this is happening so widespread (I've seen similar threads about this issue, in addition to the responses to this one) and DE hasn't given any kind of response, even just a "we're looking into it" is disheartening. I haven't done an alert since this happened because I really don't want to keep wasting my time, and the way this situation is being handled I may just view the entire game that way.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...