Jump to content
General Bug Report Guidelines - Please Read ×



Recommended Posts

After finishing every missin i´ve started, i am being disconnected after finishing it. To be specific, when mission is finished and loading screen comes up, it loads to 100% and then asks me to log in. Mission progress is kept but seems that items claimed in mission dont.

Link to comment
Share on other sites

I run like the wind, gunfire flying around me as I flee to the exit, my mission completed. I run up the ramp to my docked ship and connect to the clamps. Freedom! My ship backs away from the entry port and begins to fly away.

My vision goes black from the G-forces while pulling away from the Grineer station.


...I awake to find it was all but a dream. I lie motionless on the ground in a dead-end room somewhere in the station I invaded. I hear my heartbeat loudly in my ears. Off in the distance I hear the gravelly voice of some Grineer, are they still looking for me?  My heartbeat seems to be slowing, but why! nothing had managed to pierce my armor and the life support is still on!

My heartbeat continues to slow...then stops.

I stare into oblivion, it stares back.
True story. Today i tried to finish a mission and right after the mission complete screen where I flew off in the ship it cut to my body lying prone and limp on the grineer ship I had just done my mission in. heartbeat did slow and stop, the grineer stopped talking in the background. Then It just showed that screen until it suddenly disconnected.
I was creeped out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...