Jump to content
General Bug Report Guidelines - Please Read ×

Keyboard And Mouse Keybindings Won't Save Between Sessions


Recommended Posts

Recently, after hotfix 4.0.9, I changed a few of my keybindings. I first changed them when I was on my ship, and then reverted a few of the changes while in a match. After exiting the game and relaunching the settings had reverted to the ones I had setup on my ship.


I tried changing the settings on the ship to see if it was an issue with in-match settings being saved and the results were the same. Whether I changed them on my ship or in a match the settings would be reverted upon relaunching the game.


I then tried changing the keybindings and logging out to see if it was an account or game issue, the settings were saved between logouts but once the game was closed again the settings would revert.


Specifically the keybindings that won't save are: quick melee, melee channel, use selected power, and push-to-talk.


I haven't tried to see if the issue is all keybindings or just these few that I had modified.


I have also attempted to change only one or two of the keybindings, save, then restart with the same effect of the keybindings reverting upon game relaunch.


I used the steam "verify integrity of game cache" option after trying all this to find a corrupted file and after repairing 120 files and then re-applying hotfixes the issue still exists.


Any assitance or fixes to this matter would be greatly appreciated

Link to comment
Share on other sites

Same problem here, the game just randomly unbinds melee channel, quick melee or (sometimes) melee attack and/or Fire Weapon.

ee.cfg contains some weird lines like key=EN_GAMEPAD_LTHUMB - and I'm NOT using a gamepad at all.


TL:DR - need a fix, very annoying and potentially deadly if you find yourself without a fire button after joining mid-mission.

Link to comment
Share on other sites

I have found a possible solution, at least it worked for me.


If you are like me you have probably been using the "BACK" button in the lower right hand corner of the screen.


Instead use the back button directly under the keybindings frame and then press confirm. It should have a "Saving" logo (at least it did for me) and then it goes back to the main menu.

Let me know if this works for you guys as I have tried it twice now and it seems to be working properly on my end.

Link to comment
Share on other sites

I'm still having this problem. I've used the confirm button, and every time I exit the game my changes aren't saved. Annoying too, since the game somehow decided to save my settings from a few days ago when I was tweaking them. So over the 30 minutes or so of editing them, the game has saved what they were midway through the process, so I have messed up bindings like nothing bound to use, one of my powers bound to a numpad key, etc.


Really sucks...

Link to comment
Share on other sites

Nope, tried to use "confirm" button and it don't save keybindings. I tried it with another options changed, so the "saving" logo appears, but keybidings was not saved.


I changed my keybindings, then changed a Display Option. Upon hitting confirm, my hotkeys were also saved.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...