Jump to content

Sometimes, Wtfery Just Happens(Long Story)


Recommended Posts

I was playing a nightmare mission on Venus with my 2 nearest and dearest allies, and at the beginning, all was going well. We had no shields, but I was Oberon, and they were Rhino and an immortal-build Valkyr. My internet, the local Corpus and Zanuka decided to stage a rather frightening ambush...


About 5 minutes into the mission, our Skype call goes dead-silent. We were just happily chattering, so the change startled and concerned me. "Hello? Hey, you guys there?" I get no response. Shortly thereafter, the screen blacks out for just a second, and my party display (which I had set to display) had seemingly reset. I hit z a few time, and it occurred to me that I had been dropped from the party. I was also using an experimental immortal build, so I decided to continue onwards solo. I tried to proceed, but at some point during my blackout, the corpus engaged lockdown. I walked to the side of the door, and began hacking a nearby console. Then things get worse. as soon as I touched the console, the screen flickered. I assumed it was just because I was hacking. I completed the hack, and then the lights flicker again. Zanuka sent me its traditional "..." warning message, and I readied for the fight to come. I drew out my Sybaris, switching from my AkLex, and waited. I waited only for seconds. It spawned in behind me, and lashed into me point-blank. I spun around, and fired off, but I was too slow. It teleported away, and the shots met only the wall. I spun around, and found her, firing off a volley of shots immediately all 6 shots met their mark, but did little damage. Zanuka charged into me, and laid me flat. I continued to fire rounds into the quadruped robot until Alad V announced his pleasure at her success. As is usual, I black out, and wake up on Themisto.


The rest proceeds almost exactly as it should. I take out the first guard bare-handed, despite him being level 37. The first weapon I retrieve is my Sybaris. I immediately draw it and begin my retaliation, taking out guards with no hesitation. A few rooms later, I recover my AkLex, and draw it, as it has a slightly higher rate of fire than my Sybaris, and guards are beginning to rush me. Slowly, I thin their numbers enough to proceed, and then I find my melee, a brand new Plasma Sword. It bore only Pressure Point and its stance for mods. Yet, as I began to incorporate it into my attacks, I noted something strange about the weapon... or rather, the way I was using it. Each swing had a little more finesse to it, a little more spin and twirl. I enjoyed this oddity, it made the swings look more fluid and relentless. I drew the weapon fully, and began trying to recall the combos to it. E+E, stall, E+E+E+E... That was the first combo I tried. He danced about in a familiar manner, seeming to barely touch the weapon, yet it basically swam around him, mauling the guard I was testing it on. On the final hit, he threw the weapon in front of him. The Plasma Sword was using Gleaming Talon. I reveled in this absurdly beautiful glitch, dancing about as if I were a Jedi until I finally found my frame's powers. This was good, as my health had taken some damage during the escape, and I was able to heal. The 3rd and fourth powers were greyed out despite my 150 energy. 3 Corpus enter the room unbeknownst to me, and open fire. I round a corner, and hit 2, expecting the floor to light up, and lay a trap for my attackers. Instead, I became cloaked. I ran forward, and hit 1, attempting to smite one of them. Instead, Oberon flings 2 lethal shuriken forward, quickly bleeding the enemies out. Relying on cloaking and stealth, I manage my way to extraction very confused and  slightly upset that I would never again fling my sword into enemies, watching it sail through one, and begin spinning into the hostile behind him.


Sometimes, games just treat me oddly...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...