Jump to content
Jade Shadows: Share Bug Reports and Feedback Here! ×
Jade Shadows: Known Issues ×

Gamepad Binding Vs. Advanced Melee Combos


nipsen
 Share

Recommended Posts

I did a few searches around the net, the subreddit and the forum here - but I didn't seem to find anything about it, or even anyone having the same problem.

 

So I have a gamepad, it's using the standard xbox360 controller driver, etc. And I can bind the controls in the options just fine, etc. The doubling/switch default between guns and melee works great for me, it makes sense with a couple of adjustments to crouch and sprint, and so on.

 

And while the melee combos in the stance card sheets are displayed with the keyboard/mouse controls, they can be triggered just fine with the gamepad as is.

 

Except for the ones that use the "aim" or "secondary fire" trigger. Since these functions are bound to the left trigger, that doubles up to trigger the melee power channeling. So pushing that key doesn't also trigger whatever extra function the melee combo relies on. (If it had, it kind of wouldn't be a problem, I think).

 

And for some reason, binding either the "secondary fire" or "aim" to a different button on the gamepad still doesn't seem to work for triggering the combo. (It works perfectly fine when using the mouse button). 

 

So.. what am I missing here? Is it a third button-binding of some sort? Does the mouse input take over that function somehow? Or is it some sort of extremely curious bug with the button-doubling when the gamepad is plugged in (since I suppose more than three buttons are bound to the same function across several devices..)? Does "secondary fire" never trigger on the gamepad in the first place..?

 

Any ideas?

Link to comment
Share on other sites

Right, yes, everything works perfectly fine, really. Except for one particular key for the advanced melee combos. Down+quick-melee works fine. Pause+hold combos, no problem. But the secondary mouse button thing doesn't work somehow.. For the power-fists, for example: melee+second mouse button (default) and melee + melee + melee. The function for the second mouse button doesn't fire even though that should be bound to the left trigger.

 

I've tried remapping the secondary mouse button binding to see if it's a different key function or something like that. But.. no luck.

Link to comment
Share on other sites

  • 1 month later...

...sorry about resurrecting an old thread.

 

But I think I might have figured out what happens. It seems that the gamepad specific bindings switch out the functions of the default bindings when you change between for example melee and ranged. So when you switch to melee, the "aim weapon" key/event the combo is bound to disappears. Even if you don't bind another function on top of it, apparently (such as having aiming on the left trigger, and melee channeling when melee is primary). Probably since the function is not part of the function set in the current mode, you're not going to trigger it, so not remapping those functions even as dummy events makes sense.

 

A similar one turns up for the archwing config when binding for example context action to "x". While also binding a and x to ascend/decend. The context action (revive) won't turn up or trigger (because the flight mode overrides the default profile, and context action isn't remapped?). Meanwhile, the doubling for reload and context action works just fine. Presumably since then context action is part of the default set.

 

So I don't know -- it looks like it's the same problem. But that the events for the input become invisible when a mode-switch happens? In a way I suppose this could be solved by simply binding the combo to melee-channeling. Or to allow "alternative" double settings for gamepad as well, so that all the keys you use are bound for the specific contexts. But ideally the keys would just be mapped with the event, but the function would be overridden, so the function you want in the right context triggers.

 

..kind of happy I'm not the guy supposed to sort this out. But I'd still appreciate it if it was fixed eventually :)

Link to comment
Share on other sites

  • 2 weeks later...

This is becoming a weird investigation thread, I guess.

 

But some new information that could probably make it really easy to figure out where the problem is. The shield+sword combos on the silva&aegis with the "aim weapon"+ key actually do fire. I've double-checked several times. Meanwhile, the nikana combos don't fire, same with the power-fists, etc., with the exact same button/key-mapping.

 

So if someone at DE can check and see what the difference is between the (I suppose hardcoded) combo mapping for the silva&aegis, and the combo mapping for the nikana, then that should be it.

 

..best guesses: the combo mapping itself for the weapon mod, somewhere in the tree, has an older convention, something of that sort. Or else it has to be the actual stance, no? I.e., the only other difference that could be there between the aegis&silva and the swords is presumably that all the swords extend a different child of the sub-class than the shield/sword stance.

 

That probably would fit together with the overlap for the archwing as well. That it's a quirk with the subset implementation, not the actual mapping functions or bindings.

Link to comment
Share on other sites

  • 3 weeks later...

>_<

 

Ok. So finally figured it out. The parry button is actually the button I was supposed to press. Not only that, it was always bound to the parry button, and I didn't spot it. The keyboard binding for the (parry) function is still shown in the mod card as well. And.. it makes perfect sense on a pad that it's the parry button, because otherwise you wouldn't have enough buttons. Makes 100% sense. But. On the keyboard, secondary fire, aim and parry are all bound to the same key by default, etc.

 

So still think DE might want to look into the context precendence for certain keys/functions. Same as the reload triggering, but stopping when triggering again when a context action is present.. revive, container, etc. Revive with archwings doesn't work because of this - you always trigger the other function even if the context action lights up. Same with the order of switching weapons when picking up datamass, losing one of the weapons, etc. Dropping mass and switching weapon is one press. But that switch isn't triggered consistently when losing a weapon, that sort of thing. You don't switch (back) to secondary weapon when holding the switch button, in spite of that being the last selected weapon, etc.

 

But other than that - my bad! *facepsalm*

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...