Jump to content

For Anyone With The Endless "checking For Updates..." Problem


Recommended Posts

I figured it out, for me at least it worked..

 

Problem was the application compatibility was turned off.

so in registry, in: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AppCompat]

Change or add these and set the same values, or just create a reg file and import. Then restart.

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AppCompat]
"DisablePCA"=dword:00000000
"DisableUAR"=dword:00000000
"DisableEngine"=dword:00000000
"SbEnable"=dword:00000001

Edited by careca777
Link to post
Share on other sites

indeed, me and a friend are also suffering from the same endless update issue. I redownloaded the game on steam, he still has the stand alone client from the Closed Beta back then, and we both have the same issue still. it was working fine yesterday so something must have gone wrong with the latest update i guess.

Link to post
Share on other sites

I fixed this in a diferent way.

 

1. Run the Warframe Launcher.

2. Open the Windows Task Manager (Ctrl+Alt+Del).

3. Click on the Processes Tab.

4. Look for Launcher.exe (The Evolution Engine).

5. Right click on Launcher.exe and set the priority to High.

6. Let the launcher download the update.

 

Close the launcher and try again if it didn't work at the first try.

Link to post
Share on other sites

Agh! This is getting really frustrating. Even after a hotfix and once again trying all of the workarounds, I am still stuck in the Updating Loop of Doom. I'm starting to wonder if this game is worth all the trouble to get it to work...

Link to post
Share on other sites

I just got it to work with a much easier method.

Go to Program Files (x86)\Steam\steamapps\common\Warframe\Tools and set Launcher.exe to compatibility mode for Windows XP (Right click > Properties > Compatibility). I was able to update after that.

Link to post
Share on other sites
  • 1 month later...

not working either. win7 64x system. seems it has been completely messed up, now the directx11 check box is grey too. reinstall take forever, seems time to have a break.

 

I'm glad you mentioned about the part greyed out. This is what I am also experiencing and am using win7 x64 too,

so this is definitely related to this recent post here https://forums.warframe.com/index.php?/topic/72848-error-on-login-could-not-connect-to-the-server/

I cant believe you was having this problem back in April, yikes!

Link to post
Share on other sites

not working either. win7 64x system. seems it has been completely messed up, now the directx11 check box is grey too. reinstall take forever, seems time to have a break.

 

That's exactly my problem. The game has been running smoothly for two months, I run a mission about 3 hours ago, and now I'm stuck in checking for updates.

 

EDIT: And now, magically, as I was writing this after an hour of looking for help, it just got right by itself O_o

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...