Jump to content

Recommended Posts

same with abaddon on europa, i got a daily mission from syndicate and it was a spy. and... i got stuck in loading screen forever eventho the loading was completed, retried .... like 9 times, but still getting the same results.. *i'm still trying at this moment*....

Until now, it's still bugged along with Valac and Armaros. I'm hoping for a fix within this month. I can't finish europa and advance to other planets with this happening.

Edited by Exsys101
Link to post
Share on other sites

Ammo drops for Rifle are BROKEN! Yes I checked my ammo indicator and no they are not working properly like 50% of the time or more. In addition Rifle ammo drops you try to pick up via ammo mutation for like say a shotgun are not working properly either.

Link to post
Share on other sites

My Warframe isnt Patching the right way it tells me always there were damaged datas that were downloaded ... what should i do to fix this problem?
 

Do i need Steam now? Please Answer as fast as you can :D

Edited by Glandring
Link to post
Share on other sites

My Warframe isnt Patching the right way it tells me always there were damaged datas that were downloaded ... what should i do to fix this problem?

 

Do i need Steam now? Please Answer as fast as you can :D

 

Maybe try either verifying and/or optimising in the settings menu in the launcher. The option to verify/optimise is under the gear icon in the launcher.

Link to post
Share on other sites

DE still on vacation??

 

Its Sunday, so yes they are still out of office, (mostly since there have been images on vine of Steve showing off some new cloth physics code on Mesa). They should be back (all of them) on Monday.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...