Jump to content
Temporary sub-forum for Update 30: Call of the Tempestarii ×

Mesa Melee Bug

Recommended Posts

I hope you're ready to read a novel.

It's happening to me, too. After using only Peacemaker for the first few rounds, my melee just stopped working, and I was using it just fine a few seconds beforehand. However, I may have figured out one way to reproduce it. (Sorry for the terrible video quality.)

1. Reload your primary weapon while running backward and aiming forward.
2. Attempt to turn around.
3. Use your melee slide-attack in the middle of the turn-around animation.
4. ?????
5. Bug!


My personal THEORY as to what causes this is as follows:

When the Peacekeeper animation cancels, something bugs out and the animation is still queued in memory, and executing other certain animations in sequence, or too many animations at once, causes the sheathing animation that Mesa does after running out of energy/disabling Peacekeeper to affect other sheathe animations. This could make sense, since you are not able to melee in Peacekeeper mode, so the game doesn't know what to do, and triggers a failsafe by not allowing you to melee. This makes sense, considering your teammates can see you meleeing and you cannot, but when you attempt to melee enemies, nothing happens. There may be an overlap in animations, meaning the server gets confused and decides to show the animation to clients other than your own, but not associate a hitbox to the weapon. This, however, doesn't explain why directional melee still works. The reason you are still able to shoot weapons is that the game thinks you're still in the process of trying to switch out of Peacekeeper, to an extent where you don't have the ability activated and you're returning to normal shooting mode, therefore the instant-aim/instant-shoot is disabled and you can shoot normally. Also, after the Peacekeeper animation, when you look around the room, your character swivels around to match where your model is looking, using the same viewmodel mechanics as when you're blocking with your melee weapon out; however, this cancels when you start moving around. Before the video starts, I forgot to record that I did a slide-dash directly following the aforementioned animation. This also may be a factor in what causes this bug to happen. I've tried doing the above steps for the past hour straight, and it's only worked once out of countless tries. I doubt there's going to be a fix for it anytime soon if recreating it is this much of a pain. So, in the meantime, don't slide-attack after using Peacemaker, I guess.(Keep in mind that this may be an isolated incident and ii pure conjecture, and may have been caused by something else entirely different. I've never made a game, I'm basically talking out of my ! here.)

Drinking game: Take a shot every time you read the word "Peacekeeper" on this post.

This is what happens when you make a gun-toting frame use a melee weapon. She obviously doesn't want to use it, so why force her? This is obligatory systemic female oppression, and I hereby demand that Mesa should not be allowed to use, or even hold a melee weapon. Make it happen, DE.

please don't take that last paragraph seriously i love coptering

Edited by RaitoKunRyuk
Link to post
Share on other sites
  • 2 weeks later...
  • 5 weeks later...
  • 5 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...