Jump to content
  • 10

[Guide] Warframe On Linux With Wine


HACKhalo2
 Share

Question

Alright, so after much acclaim from the Subreddit, I decided to post my walkthrough on how to get this game running somewhat decently under the newest Wine (Development 1.5.29). The direct link to it is http://www.reddit.com/r/Warframe/comments/1dnnoj/warframe_on_linux/.

 

Alright, so first thing. I did this in Arch Linux, so your mileage will very depending on what distro you use. I've read good reports for Ubuntu working pretty easily, and other distros not so much. I would like feedback on what extra steps you would have to do to get it to work if mine didn't work for you.

 

Step one, Install Wine (I recommend Dev, but Stable may work) and, if your Package Manager doesn't package it together, winetricks. http://www.winehq.org/ for wine, and https://code.google.com/p/winetricks/ for winetricks. Optionally, create a prefix for Warframe so you don't clutter up the default one.

 

Step two, run winetricks d3dx9 xact (or /path/to/winetricks.sh d3dx9 xact if the package manager didn't install it). This will install the bare minimum DirectX9 and XAudio2 DLL's needed by most games. (You can omit d3dx9 for directx9, but that's usually overkill)

 

Step three, Download the Warframe.msi and put it somewhere you'll remember. I have mine on my Desktop.

 

Step four, open a terminal where the Warframe.msi file is at and run wine msiexec /i Warframe.msi. This will start the launcher. (You can optionally run wine msiexec /i /path/to/Warframe.msi)

 

After this step, the Launcher Window should open up. If it doesn't, try installing 'lib32-openal', 'lib32-libxml2', 'lib32-mpg123', 'lib32-giflib', 'lib32-libpng', and 'lib32-gnutls'. These are common compatibility libs most Wine programs need, so it wouldn't be to awful to install them all. These are also the names Arch Linux gives these packages, so you may need to Google around for the correct names for your Distro.

 

This is a (incomplete) list of Package names per DIstro. (Thanks Morcant!)

Arch             Ubuntulib32-openal     libopenal1lib32-libxml2    libxml2lib32-mpg123     libmpg123lib32-giflib     libgif4lib32-libpng     libpng12-0lib32-gnutls     libgnutls26

On a 64-bit system with multiarch, it may be necessary to use e.g. 'sudo apt-get install libgnutls26:i386' to install the 32-bit packages.

 

Step five, after the launcher opens up, DISABLE 64BIT IN THE LAUNCHER SETTINGS. It currently does NOT work right, and you're going to have a bad time.

 

Step six, Hopefully the launcher will be complaining about not being able to find Launcher.exe in your AppData path ($WINE_PREFIX/drive_c/users/<your username>/Local Settings/Application Data/Warframe/Downloaded/Public/Tools/Launcher.exe). It is there, but you need to move it over manually. CD into the directory and run mv Launcher.exe.tmp Launcher.exe. Click Retry on the launcher, and it should greet you with the login prompt. Enter your login information, and hopefully you will see the Licensing conditions. If so, congrats! Enjoy playing Warframe on a non-Microsoft system!

 

There is a chance that you will get the error that dreaded me for almost two weeks, the Could not log in: Could not find Server error. I have no clue why this error is there, but it fixed itself by compiling and installing https://github.com/madewokherd/wine-mono (https://aur.archlinux.org/packages/wine-mono/ for you Arch Linux users). It takes quite a bit of time to compile (I have an A10-5800K, and it took around 30 minutes to compile and install). MAKE SURE YOU HAVE A LOT OF SPACE IN /tmp, IT WILL TAKE A LOT JUST TO COMPILE IT!

 

If that doesn't fix it, Try compiling Wine from source. it's a long shot, but it may work (and it has worked for some people).

 

TIPS AND TRICKS

 

If your sound doesn't work (and it doesn't complain about not finding the XAudio2 Engine), try modprobing snd_seq. It may not of been loaded.

 

If your sound doesn't work (and it's complaining about not finding the XAudio2 Engine), run winetricks --force xact_jun2010. It may of not installed correctly the first time.

 

If the preprocess crashes when first starting the Launcher, run the launcher (or Warframe.msi) in the terminal. It fixes this error for me.

 

TURN OFF ALL THE FANCY STUFF AND HAVE THE GAME IN FULL SCREEN MODE. It raised my FPS from 10 to 60+.

 

Hopefully this guide helps you!

Edited by HACKhalo2
  • Like 2
Link to comment
Share on other sites

Recommended Posts

  • 2

Alright, what you guys wrote above fixed it for me. Warframe's running like a charm again. Maybe the recent update helped too, but without the fix it still didn't run.

Here's what I did:

I changed my Wine version for Warframe inside of PlayOnLinux to a newer staging version that what I had running. I now use 1.9.3 staging for 32 bit Warframe and 1.8 staging for 64 Bit Warframe.

Inside PlayOnLinux I went to the configuration window of my Warframe. There I installed the following components:

mfc42; mscxml3; vcrun2012

Then I checked my Wine configuration, there's a button to get into that in POL, to have following libraries installed:

mfc42; mfc42u; msxml3

Of course, if you are smart, you reverse these steps to see if you even need to press those install buttons.

Then I went to the staging tab and enabled CSMT, as I now get only very laggy FPS numbers without that.

I let Wine emulate Windows XP without a virtual desktop. I also set the option to capture my mouse courser in fullscreen.

Overall I tested Warframe with those things installed on Wine 1.7.3 32 bit, Wine 1.9.3 staging 32 bit, and Wine 1.8 staging 64 bit. All versions run on my machine and I am able to run Warframe in the 64-bit version (at least my launcher tells me that it is) without any bigger problems. However, the 64 bit launcher is unstable and tends to crash. Once ingame, Warframe runs stable. Still running Dx9, obviously.

In Warframe I have dynamic lighting and adaptive exposure deactivated, as they give me lighting bugs. I have activated all other graphical settings, am playing all high and got 4x anisotropic fitlering, defailt trilinear filtering and SMAA (high) anti-aliasing settings.

My Warframe runs in borderless fullscreen which, for me, eliminates plenty bugs that come with fullscreen. I can tab out no problem and my mouse courser is held properly ingame by Wine.

 

Cheers to the lot of ya finding that out!

Link to comment
Share on other sites

  • 1
9 hours ago, SKRUBLORD_64 said:

For U18.5, the launcher instantly crashes after downloading 302 kb of the update, and restarts immediately and does the same thing over and over again. Anyone else having this issue? I wanna play sands of inaros but the game won't get past the launcher. 

 

P.S. I'm pretty sure it's been able to download updates fine before, assuming there's been updates between 17 February and now. Although I never really paid attention to the updating part I guess. 

I'm considering reinstalling WF but I just want to know for sure that this isn't a server problem or a simple fix before I do so.

I had the exact same problem. I had an .exe.tmp file appear again, I just had to delete the .exe and rename the .exe.tmp to .exe and it worked. If this doesn't work, I had the problem as well before I reinstalled my system and warframe and the fix then was to use the LauncherCEF.exe to update.

Black textures are worse than before and there seems to be a lot of fog everywhere (only exception would be in some corpus missions). I've tried changing the settings but I haven't found how to make it better. If any of you has an idea/fix, let me know.

Link to comment
Share on other sites

  • 1

After 18.5.5, it appears that after loading the launcher completely and clicking play, the loading screen right before the login screen always stops responding and crashes at around 60 percent of the way through. The warframe bug reporter always pops up afterwards too, so it doesn't seem to be a Wine error, at least on the surface. Verifying and optimizing the cache does not seem to have any effect. If anyone has any possible solutions it would be greatly appreciated.

Link to comment
Share on other sites

  • 1

I have the same error and have experimented with it for some hours (spoilers: without success). I have tried multiple reinstalls on multiple drives, 32 bit or 64 bit wine drives, multiple wine versions. So far, I get similar results in all combinations. 64 bit Warframe now runs just in the same way as the 32 bit for me: not at all.

When starting up the load screen, debugging it throws out tons of errors, usually unable to load this and that file. Probably what caused the missing or corrupt textures before this hotfix (when Warframe at least run). Among them is a line stating that the game now requires a newer version of nvidia drivers than, at least for me, is yet provided for Linux. So, if you have one installed, check out how far your version is behind the newest. I can imagine that, as Warframe currently only supports Windows, the minimum is still further up than our driver versions. Strangely, in the 64 bit build I couldn't find that line.

An interesting thing to note as well is that, in my case, the game often crashes in different parts of the loading. Sometimes it's around the 75% mark, sometimes the loading practically completes, very rarely I even get some notes from the login screen's music before the game engine crashes. The furthest I get by disabling multi threaded rendering in the launcher.

Then there's that: Error [Debug]: Loaded unexpected version of dbghelp.dll from C

I tried to reinstall said dll via winetricks as well as copying directly into the sys32 and Warframe directory of the drives, the error always stayed. This is also the last error I get before Warframe crashes.

Once it ended on:

err:dbghelp:SymCleanup this process has not had SymInitialize() called for it!
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x1100ba

I tried to load several dbghelp.dll versions from the internet and override mine, but nothing ever changed. It would be a too hard guess work to hit the version Warframe expects.

Link to comment
Share on other sites

  • 1
9 hours ago, julespetrikov said:

I'm reinstalling wine-staging as we speak, thank you for the information. Though, wine itself wasn't that big of a problem for me, I was staying away from interception missions because I wasn't quite confident in playing them under wine and be able to work fast to keep it up with the game. Surely, there are hiccups but overall it was quite playable for me. But, yeah, the longer game ran, messier the lag got.

I'll be setting up wine-staging for trying the game out. I hope this issue gets resolved as soon as possible.

The script I use to launch it from wine-staging, in case you find it useful:

Quote

#!/bin/bash

# remove old log
rm "$HOME/Desktop/Wine/Wine Logs/wineframe.log"

# add wine-staging to PATH just for this script
PATH="/opt/wine-staging/bin:"$PATH

# fix for a failed launcher update
LAUNCHER="/media/$USER/Secondary/WineGames/Wineframe/drive_c/users/$USER/Local Settings/Application Data/Warframe/Downloaded/Public/Tools"
if [[ -f "$LAUNCHER/Launcher.exe.cpy" ]]
then
  rm "$LAUNCHER/Launcher.exe"
  mv "$LAUNCHER/Launcher.exe.cpy" "$LAUNCHER/Launcher.exe"
  chmod 755 "$LAUNCHER/Launcher.exe"
fi

# kill off any wineframe leftovers from a failed launch
pkill -f Launcher.exe
pkill -f Warframe
pkill -f winedbg

# allow warframe to launch without keeping a terminal open
# also logs all output
WINEPREFIX="/media/$USER/Secondary/WineGames/Wineframe" nohup wine "/media/$USER/Secondary/WineGames/Wineframe/drive_c/users/$USER/Local Settings/Application Data/Warframe/Downloaded/Public/Tools/Launcher.exe" &> "$HOME/Desktop/Wine/Wine Logs/wineframe.log" &

# sleep to allow time for the background process to start
sleep 2

And while I'm at it, my full log of the crash.

Link to comment
Share on other sites

  • 1
2 hours ago, JohnTheGreen said:

The screenshot didn't load for me, so I installed vcrun2013, which didn't work, then I installed vcrun2010, vcrun2012, vcrun6, and vcrun6sp6 and it worked! (servers having there own connection issues still though)
 

This also worked for me! seems to be a solid solution thus far. Will report on how new textures are doing shortly.

Edited by PhantasmalWraith
Link to comment
Share on other sites

  • 1

This is weird... somebody posted the solution here from another thread in the forum, I answered and so did one other person, yet none of that appears here.

That's the solution that worked for me and a lot of other people who had the same problem.


EDIT : see below, I wanted to edit this post as I messed up with the quote from the other thread, it posted another comment instead

Edited by CountrifiedSoul
Link to comment
Share on other sites

  • 1

Here is the solution, for some reason, it posted another message instead of updating the one before...

8 hours ago, Prototype_X9 said:

Fixed. If you are running winetricks, download the updated versions of vcrun.

 

Attached in screenshotScreen_Shot_2016_03_12_at_9_42_47_PM.png

 

Edited by CountrifiedSoul
Link to comment
Share on other sites

  • 1
1 minute ago, SKRUBLORD_64 said:

vcrun2012 isn't showing up for me, all I'm seeing are 2003, 2005, 2008, 2010, 6, and 6sp6. What do I do?

Edit: I don't believe I have any of them installed yet either.

Someone mentioned trying to update Winetricks for that.

Link to comment
Share on other sites

  • 0

Thank you very much for posting this. I will see about ways this can be done for the MacOSX folks. Sadly we don't have a Binary installer for Wine at the moment, so all us Mac folks are going to be looking at some custom Terminal time. My first go will be to see if PlayOnMac will work.

Link to comment
Share on other sites

  • 0

Sorry for this newb question but im pretty new to linux.. I get this problem: ´´If the preprocess crashes when first starting the Launcher, run the launcher (or Warframe.msi) in the terminal. It fixes this error for me´´

 

How do i launch warframe in the terminal? I've tried multiple ways (Atleast i think so..) but it never launched warframe D:

Link to comment
Share on other sites

  • 0

What did you type? What error did you get? Have you tried this:

 

Step four, open a terminal where the Warframe.msi file is at and run wine msiexec /i Warframe.msi. This will start the launcher. (You can optionally run wine msiexec /i /path/to/Warframe.msi)

Link to comment
Share on other sites

  • 0

Sorry for this newb question but im pretty new to linux.. I get this problem: ´´If the preprocess crashes when first starting the Launcher, run the launcher (or Warframe.msi) in the terminal. It fixes this error for me´´

 

How do i launch warframe in the terminal? I've tried multiple ways (Atleast i think so..) but it never launched warframe D:

 

 

What did you type? What error did you get? Have you tried this:

 

Step four, open a terminal where the Warframe.msi file is at and run wine msiexec /i Warframe.msi. This will start the launcher. (You can optionally run wine msiexec /i /path/to/Warframe.msi)

 

Basically this. A terminal is like Command Prompt in Windows. It's usually bound to a shortcut (mine is Ctrl+Alt+T). All you do is open your Terminal and run the above command to "run" Warframe in a Terminal. It will output a bunch of fixmes and stuff from WINE, and some debug from Warframe itself, but that's normal.

 

And as Windbow said, what's the exact error message your getting?

Link to comment
Share on other sites

  • 0

jamie@jamie-VC873AA-ABH-p6130nl:~$ run wine msiexec /i /path/to/Warframe.msi
No command 'run' found, did you mean:
 Command 'zrun' from package 'moreutils' (universe)
 Command 'runq' from package 'exim4-daemon-heavy' (main)
 Command 'runq' from package 'exim4-daemon-light' (main)
 Command 'runq' from package 'sendmail-bin' (universe)
 Command 'grun' from package 'grun' (universe)
 Command 'qrun' from package 'torque-client' (universe)
 Command 'qrun' from package 'torque-client-x11' (universe)
 Command 'lrun' from package 'lustre-utils' (universe)
 Command 'rn' from package 'trn' (multiverse)
 Command 'rn' from package 'trn4' (multiverse)
 Command 'rup' from package 'rstat-client' (universe)
 Command 'srun' from package 'slurm-llnl' (universe)
run: command not found
 

Link to comment
Share on other sites

  • 0

jamie@jamie-VC873AA-ABH-p6130nl:~$ run wine msiexec /i /path/to/Warframe.msi

No command 'run' found, did you mean:

 Command 'zrun' from package 'moreutils' (universe)

 Command 'runq' from package 'exim4-daemon-heavy' (main)

 Command 'runq' from package 'exim4-daemon-light' (main)

 Command 'runq' from package 'sendmail-bin' (universe)

 Command 'grun' from package 'grun' (universe)

 Command 'qrun' from package 'torque-client' (universe)

 Command 'qrun' from package 'torque-client-x11' (universe)

 Command 'lrun' from package 'lustre-utils' (universe)

 Command 'rn' from package 'trn' (multiverse)

 Command 'rn' from package 'trn4' (multiverse)

 Command 'rup' from package 'rstat-client' (universe)

 Command 'srun' from package 'slurm-llnl' (universe)

run: command not found

 

Ah, It's just wine msiexec /i /path/to/Warframe.msi, where the path is the absolute (or relative in some cases) path to the file. So for me, it would be wine msiexec /i /wd/Games/Warframe/Warframe.msi. Your not going to have a /wd/ directory, since that's my mount point to my storage hard drive. Usually, you'll have a Downloads directory in your home folder. You can check by running ls in the home directory (with is denoted with a ~in a terminal, usually in a YourName@ComputerName:~ fashion. If your not in the Home directory, run cd ~ to get there). More then likely, Warframe.msi is going to be there.

Link to comment
Share on other sites

  • 0

Uhm... try again, without the "run". Don't worry, you'll get the hang of it. We were all newbies once.

Sorry, you need to also include the path to the msi file. The above is just an example.

 

Do you  know where you downloaded the file? See in your file manager.

 

Btw what distro are you using? Ubuntu? LinuxMint? It can help us help you if we knew what you're using.

Link to comment
Share on other sites

  • 0

Sorry for the amount of questions but what do i change  if i have the msi on my desktop?

Thanks for the help :)

The command would be wine msiexec /i ~/Desktop/Warframe.msi if the file is on your desktop.

Link to comment
Share on other sites

  • 0

Thanks! Now the launcher came up but the text is white and it seems its stuck at ´Downloading new content´ about halfway.

 It's going to do that. Did you disable 64 bit mode? If you did, just wait patently. Read a book, or browse reddit for a while, or watch TV. It took me about 10 minutes to get the first run of data.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...