Jump to content

Archived

This topic is now archived and is closed to further replies.

PairedPrototype

[Solved] Has Mag Been Nerfed Or Is It Just A Bug?

Recommended Posts

Okay so I came on this morning to find that there's been an update (oh yay), great job on the UI by the way, anyway I decided I'd jump on and do the event (20 cores! yes get in) and as always, I took my favorite frame, Mag. All was going good then I decided to stock up on my shield (as you do), only to find that it was severely limited, I put it down to being a Grineer mission because they don't ever seem to have shield to steal so it'd make sense. 

But I was wrong, I went to do a void mission, and I've come to a conclusion that Mag was nerfed or there's a bug, see, usually I could use shield polarise and gain around 100 shield points (more if there was shielded enemies of course) each time I used it upto 1627 points (I think, but for sure over 1600). Now, there *has* to be enemies around with shield or else I lose shield every time I polarise until it's just 1 point above my max regen. 

I've got a video below too (this time in better quality). Please could you tell me if this is a bug? I really hope it is! Please don't nerf my Mag :'(

https://youtu.be/ibLj1G1xx_M

Share this post


Link to post
Share on other sites

The nerf already happened, but what that looks like in the video is a bug.

 

However, are you sure you were not taking any hits from enemy fire while camping like that?  That may have been the case too.

Share this post


Link to post
Share on other sites

The nerf already happened, but what that looks like in the video is a bug.

 

However, are you sure you were not taking any hits from enemy fire while camping like that?  That may have been the case too.

 

But in chunks of like 500 when I polarise? And the fire was one of the other frame's abilities, as you can see I wasn't constantly taking damage. 

Share this post


Link to post
Share on other sites

WOW definitely a bug right? You were literally reducing your shields everytime you use shield polarize in the middle of the video.

 

But at the end it turns back alright is it?

Share this post


Link to post
Share on other sites

WOW definitely a bug right? You were literally reducing your shields everytime you use shield polarize in the middle of the video.

 

But at the end it turns back alright is it?

 

It went up the last time, I'm assuming, because there was enough shield from enemies in range to take.

Share this post


Link to post
Share on other sites

Its a bug thats for sure if u have a 2nd mag using SP all ur overshield will be gone :(

Share this post


Link to post
Share on other sites

It has to be a bug. I tested this last night for 2 hours in the void and it's terrible. What's worse is that it negates the Overshield Trinity and Volt get from their Augment mods too.

Share this post


Link to post
Share on other sites

It has to be a bug. I tested this last night for 2 hours in the void and it's terrible. What's worse is that it negates the Overshield Trinity and Volt get from their Augment mods too.

 

Aww, thats gotta suck real bad!

Share this post


Link to post
Share on other sites

Hot fix inbound, with mention of fixing shield stuff. Although it was stated specific for the Nightmare mode, it might also fix the problem for Mag :) I'll let you guys know! 

Share this post


Link to post
Share on other sites

×
×
  • Create New...