Jump to content
General Bug Report Guidelines - Please Read ×

Nvidia Display Driver Crashing


jellybean1909
 Share

Recommended Posts

Recently I've had this problem where my screen at random points in the game will go blank and when it starts back up my game is just a grey screen and I've tried many fixes most just adding a few moments to the inevitable crash. My game seems to still run as I've played online and a friend said that my character was still reacting to my inputs and I can still hear all audio.

 

I've tried the Nvidia tdr fix which hasn't extended the time or anything.

 

It was running fine before on the same drivers, I played the game almost all day but it crashed later in the evening after the better half of 12 hours.

Edited by jellybean1909
Link to comment
Share on other sites

I don't like overclocking and my power supply is above the recommended to run the setup I have.

 

Also after disabling the TDR it made my computer freeze with audio working then the audio stopped I'm not truly sure if it crashed

Edited by jellybean1909
Link to comment
Share on other sites

I believe so. I'm not the best at computers to understand if that has any impact.

 

I recommend checking your in-game visual settings to ensure that Warframe's v-sync is enabled. You may be pushing your video beyond its limits if this has been disabled. 

Link to comment
Share on other sites

It's enabled and I did play this game perfectly fine for the most part of a day (as I stated at the start) and I haven't changed my settings since then.

 

Other then suggested of turning 32 bit, 64 bit and multi-thread rendering off and on in different combinations.

Edited by jellybean1909
Link to comment
Share on other sites

That means you have another issue than just TDR. Are you overclocking you CPU and or Video Card or maybe running an undersized power supply for your components?

actually, no. it's a TDR problem. Same issues here. Started with U16 early hotfix. Been playing since closed beta started and never had any issues at all.

 

I've rolled back to a pre-U16 driver (GTA V release) and even a few earlier, and still the same issues. the Nvidia fix seems to have made it somewhat better, but I can't not run mastery tests without crashing.

Edited by SluggoV2
Link to comment
Share on other sites

I'm having this issue too. Based on some web searching, I think the problem isn't from TDR or GPU (unless it's OC'ed.) TDR is merely a safeguard built in to Windows that is used to reset the driver if it hasn't responded for several seconds.

 

On default, TDR kicks in after 2s the driver stopped responding. You can change the default delay by changing the TdrDelay. The risk of changing the delay is it may cause your system to crash if the driver stops responding.

 

To sum it up, the crash is most likely caused by NVIDIA display driver or nvlddmkm. You might want to check Event Viewer > Custom Views > Administrative Events to see if it's either the game or the driver.

Link to comment
Share on other sites

A lot more help would be available on hand if you could provide the details to your hardware etc.

What driver are you running?

Sorry I forgot that.

My driver is 353.38

Gpu: Nvidia GTX 980

Cpu: i7-5820k

12GB ram

Windows 7 (unsure if anything else is needed)

 

Found a potential fix (not played long enough yet) but putting the clock speed down by 100 mhz seems to of solved it so far

Edited by jellybean1909
Link to comment
Share on other sites

If your clock speed was affecting the game process, your gpu could have been unstable.

Have you tried limiting the FPS output on your GPU? A 120 frame limit test could provide some information.

Well I run games like GTA V and every Crysis game all fine its literally just this game that is effected but with my clock speed down by 100mhz its fine and I get no performance loss so just going to keep it like this.

 

Guys try disabling Aero themes, it worked for me, no more TDR or crash on w7.

http://www.howtogeek.com/howto/windows-vista/disable-aero-on-windows-vista/

This didn't work for me it did nothing in fact it may of made my problem worse.

Link to comment
Share on other sites

  • 3 months later...

I have a similair problem myself. Running 2x GTX 970's (EVGA ACX 2.0 SSC) with an extra 120 mhz tuned in, and they are rock frigging steady running everything. I've tested over and over again, so I know the clock itself is stable. So unless the... Evolution engine? Is throwing a hissy and crashing because it doesn't like my setup, I have no idea what's going wrong

I also know the game isn't overloading my system lol. I have crank Witcher 3 up to over double the "maximum" graphics settings to get to an 80% GPU load.

Edited by BulletsforTeeth
Link to comment
Share on other sites

  • 2 months later...

Digging up old stuff i know, buuut in case others have this issue (which im sure tons do)..

this crash is a maxwell (should be mostly) card issue (aka 900 series) switching between different power modes (normal clocks, boost speed, energy saving etc)

 

So try going to the control panel and from Manage 3d Settings>Program Settings> from there select "Warframe.exe" > and there change "Power management mode" from "adaptive" to Prefer Maximum performance.

 

Also make sure you're not running any custom over-clocks etc ofc.

 

Especially mid to high and high end will have issues since the game is lets say... weak gfx wise on the card load so these cards are often going in and out of normal to high performance speeds and back constantly.

 

Last but not least, if all of the above didnt do the trick for you, simply use something like MSI afterburner, to Down-clock your graphics card. Simply get your Core Clock to something like -30 or -40 Mhz and it will also help prevent the issue from re-occurring. Just remember to go back and reset to normal speeds when you want to play another game with the normal full speeds.

Edited by Cailian
Link to comment
Share on other sites

  • 3 weeks later...

Digging up old stuff i know, buuut in case others have this issue (which im sure tons do)..

this crash is a maxwell (should be mostly) card issue (aka 900 series) switching between different power modes (normal clocks, boost speed, energy saving etc)

 

So try going to the control panel and from Manage 3d Settings>Program Settings> from there select "Warframe.exe" > and there change "Power management mode" from "adaptive" to Prefer Maximum performance.

 

Also make sure you're not running any custom over-clocks etc ofc.

 

Especially mid to high and high end will have issues since the game is lets say... weak gfx wise on the card load so these cards are often going in and out of normal to high performance speeds and back constantly.

Thanks for posting this mate, this is currently the top result on the search I did and your solution helped me a lot :)

Link to comment
Share on other sites

Digging up old stuff i know, buuut in case others have this issue (which im sure tons do)..

this crash is a maxwell (should be mostly) card issue (aka 900 series) switching between different power modes (normal clocks, boost speed, energy saving etc)

 

So try going to the control panel and from Manage 3d Settings>Program Settings> from there select "Warframe.exe" > and there change "Power management mode" from "adaptive" to Prefer Maximum performance.

 

Also make sure you're not running any custom over-clocks etc ofc.

 

Especially mid to high and high end will have issues since the game is lets say... weak gfx wise on the card load so these cards are often going in and out of normal to high performance speeds and back constantly.

 

Last but not least, if all of the above didnt do the trick for you, simply use something like MSI afterburner, to Down-clock your graphics card. Simply get your Core Clock to something like -30 or -40 Mhz and it will also help prevent the issue from re-occurring. Just remember to go back and reset to normal speeds when you want to play another game with the normal full speeds.

I've had this problem multiple times, going to try this

Link to comment
Share on other sites

  • 2 weeks later...

Ive also had these issues and i talked to support, got absolutely nowhere. was told to reinstall windows, already did that before and it didnt do anything (my windows install is barely two weeks old)

How I see it you may want to contact nVidia technical support regarding the drivers and/or computer part manufacturer regarding your hardware. Also advisable would be to contact the computer store from where you bought your PC / hardware for the compatibility issues: eg. if your psu doesn't give stable power for the display adapter causing adapter or driver crashes. Atm. all you can do by yourself is to narrow down the problem via testing.

 

Edit: You could also analyze with GPU-z what happens when you experience the display adapter or driver crash - is it related to gpu choke, voltage, heat and so on:

If8bcyo.jpg

http://i.imgur.com/If8bcyo.jpg

Edited by carnaga
Link to comment
Share on other sites

I managed to install the 347.88 Driver (with my 980TI ! ) and have not yet experienced a crash.

If nothing else works a rollback to this Driver might just do the trick :)

 

Edit: Oh well, it ran fine for almost two days... crashed again.

Edited by BlizzardMamba
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...