Jump to content

Archived

This topic is now archived and is closed to further replies.

Raniu

Bug In Ui Displaying Incorrect Kubrow Stats

Recommended Posts

Dear DE, thank you for fixing the annoying "downed" marker appearing on the map even after a downed Kubrow was revived (the bug is still there but not related to Kubrows this time). BUT. Even more annoying bug appeared in the UI introducing even more confusion.
 
I had multiple instances of my Kubrow appearing in the companions UI as downed/reviving despite it being safe and sound and the very opposite: my Kubrow appearing in the companions UI as healthy despite it being actually downed/reviving/dead. More often dead though, hardly ever downed/reviving since I HAD NO IDEA IT TOOK FATAL DAMAGE as for the UI would show the Kubrow being just fine >:(
 
 
Update!
It's confirmed that the bug occurs after player revives. The UI part responsible for displaying companion health/shields/bleeding stats shows what the stats were when companion's owner revives and doesn't change.
 
Now that we know it it should be fixed soon, right? Right?
 
 

Pictures: (look at Kubrow stats)

cL8eQbE.jpg

 

mWBMy4z.jpg

 

eKiukrP.jpg

 

lZr4DtN.jpg

 

gDcjsaK.jpg

 

wnjEonH.jpg

 

You're amazing, DE, keep up the good work. I know that fixing some bugs is really difficult sometimes, especially if you're not provided with the reproduction steps, but the players believe in you <3

 

We now know what causes the bug fortunately.

 

Looking forward to a fix! And thank you in advance.

 

 

Share this post


Link to post
Share on other sites

And what colour are you using on those aksomati? I did a double-take 'cause I though they were some prime dual pistols I missed.

Share this post


Link to post
Share on other sites

What resolution you play on dude :D your game loks amazing O.O 

 

1440p

 

And what colour are you using on those aksomati? I did a double-take 'cause I though they were some prime dual pistols I missed.

 

Halloween middle yellow appears the most goldish of all colors available for players to me. So I use it to sorta "prime" things.

 

 

I'd rather you guys post some other funny pictures of the bug than ask irrelevant questions :<

Share this post


Link to post
Share on other sites

This actually also occurs for players in group missions occasionally.  Leaving the red indicator after reviving a player, unknown if it happens for all players seeing the same indicator though.  I do know I'm usually a client when it happens.

Share this post


Link to post
Share on other sites

This actually also occurs for players in group missions occasionally.  Leaving the red indicator after reviving a player, unknown if it happens for all players seeing the same indicator though.  I do know I'm usually a client when it happens.

 

Seen that a few times. Especially when the network was lagging noticeably.

 

... Programming for parallel processing is hard; although generally an issue like this is solved by full-state sync similar to the host migration process, that's way less trivial for a realtime thing e.g. a game.

Share this post


Link to post
Share on other sites

I think the issue occurs after the player revives. UI then bugs and shows Kubrow's stats as they were when the player revived.

Share this post


Link to post
Share on other sites

I think the issue occurs after the player revives. UI then bugs and shows Kubrow's stats as they were when the player revived.

I can confirm ^

Share this post


Link to post
Share on other sites

I do the same thing with my Aksomati. I would love it if DE made a prime version of the Aksomati. Until then, I make mine look like they are. The Aksomati are just one of the best secondary weapons in the game.

Share this post


Link to post
Share on other sites

×
×
  • Create New...