Archived

This topic is now archived and is closed to further replies.

BlaineKodos

Power Menu Stuck After Opening Since 18.0.4 If Remapped

Recommended Posts

Loaded into a mission after updating, and upon opening my Power Menu, it remains open regardless of input. I'm on a 360 controller (which is what the menu's for) and trying to use any abilities instead removes me ability to press a face button. No context actions, parkour, jumping or weapon swapping is possible as the menu does not close. Holding the Power Menu button and pressing it does nothing. Resetting the controls to default fixed it, but resetting my controls back to how I like caused it to stick again. This was not an issue before the hotfix, so I doubt it is my controller.

 

EDIT: It seems to be only when I map Power Menu to LB, but... it's acting strange. For the Power Menu to be stuck open, one would assume the button is registering as being held down, yes? But mapping Fire Weapon to LB (to test if my automatic weapon would continue firing) it functions as it is supposed to. Tapping gets one shot, holding gets automatic fire, releasing stops the firing immediately. Power Menu functions as intended on both RB and RT. This cannot be hardware failure based on my testing.

 

EDIT 2: Tried again after 18.0.4.1 just to see if wires crossed and uncrossed, and problem persists. Also tested with a new frame and some new equipment, the problem is identical. Power Menu sticks on LB and not on any other buttons. I also noticed that with Excalibur at least, activating Exalted Blade caused the Power Menu to close, but none of his other powers did this. When opening after Excalibur activates Exalted Blade, it goes right back to sticking unless I want to turn Exalted Blade off.

Share this post


Link to post
Share on other sites

Hi BlaineKodos,

 

Thank you for bringing this to our attention, this definitely sounds related to a change that went into the game today (18.0.4) which was designed to make the new Focus Power accessible through the Power Menu (with the default binding for it being LB). I will personally look into this issue and hope to have it resolved before too long!

Share this post


Link to post
Share on other sites

Hi BlaineKodos,

 

Thank you for bringing this to our attention, this definitely sounds related to a change that went into the game today (18.0.4) which was designed to make the new Focus Power accessible through the Power Menu (with the default binding for it being LB). I will personally look into this issue and hope to have it resolved before too long!

Thanks a bunch! I've been using LB for my powers for two years, so trying to adapt to a new button would have been a pain.

Share this post


Link to post
Share on other sites

Same here and i want to add that sometimes when the menu stucks pressing LB sometimes cast focus wich is set to the digi-cross for me,

and befor the update a short press of the LB triggered the last power what is not working anymore too.

Share this post


Link to post
Share on other sites

Also just wanted to mention that this is not a new bug, just the focus interaction is new.

 

This bug occurred previously, I think with U17 although I could be wrong on the timing (I filed a bug report then too). In the previous occurrence the ability menu would stick open once activated just as it does now, but you could trigger the ability menu command again to toggle it off. Now when you try to use the ability menu command to toggle the menu off it just triggers focus mode instead. Wanted to make sure this information was included here in case the resolution to the previous incarnation of this bug would be useful to fixing this version of it.

 

Best of luck guys, I'm still hoping to be able to complete todays sortie.

Share this post


Link to post
Share on other sites

Hopefully this is fixed soon. Being unable to use the power menu on a 360 controller makes using powers a lot more annoying to do.

Share this post


Link to post
Share on other sites

Hi BlaineKodos,

 

Thank you for bringing this to our attention, this definitely sounds related to a change that went into the game today (18.0.4) which was designed to make the new Focus Power accessible through the Power Menu (with the default binding for it being LB). I will personally look into this issue and hope to have it resolved before too long!

 

Can we get a fix for this too while we're at it please?

 

https://forums.warfr...g/?hl=navigator

https://forums.warfr...n/?hl=navigator

https://forums.warfr...2/#entry6499570

Share this post


Link to post
Share on other sites

after the recent update the bug is back

Strangely, even though everything on my end is the same, this bug has not returned for me. In fact, the power menu only got better on my end as it put Power E onto RB without my input. It's just there, where I wanted it to be anyway. Everything works as it should. It seems to be very selective.

Share this post


Link to post
Share on other sites

I've still had the controller bug after this recent Hotfix. However after reading through this thread it came to my attention that if I remap the Focus power to RB then I would have no problem.

Share this post


Link to post
Share on other sites

First time I've played in a week or two, and I'm having the same bug with my xbox controller. Game was essentially unplayable for me. But rebinding power E to right bumper, and then re-rebinding melee back to right bumper fixed it.

Share this post


Link to post
Share on other sites