• Announcements

    • [DE]DrewDev

      General Bug Report Guidelines - Please Read   03/31/2016

      ***Before posting in General bugs, make sure your report doesn't belong in any of our other bug categories.***   Bug reports are the key to identifying and fixing issues in Warframe. We rely on our forums heavily for identification of bugs plaguing Tenno in the field. In order to improve on our ability to act on bugs, there are some steps you can take to help us keep the forum organized. This will help our team to prioritize fixes, allowing us to serve the community where we are needed most. Before posting on the bug forums, please read the following guidelines:

      1) Search! Check to see if your bug has already been reported using our search function within the appropriate bug forum. If the issue has been reported previously, please comment on that thread instead of making a new one. In addition, some problems can only be solved by support; be sure to read this thread if you are unsure of where to submit your report.
           
      2) Separate! If you have found multiple bugs, please separate them into one bug per thread. Even if the same item/ability/etc. is affected by multiple issues, keep them separated unless they are very closely linked, or the same bug can be recreated in two or more ways.
           
      3) Specify! Make sure that your thread title is informative, indicating:
      a. Which element(s) of the game are affected
      b. How the bug affects these elements
           Helpful titles:
      Unable to perform melee finishers after using Ash's Teleport
      Event Badge in wrong position on Sentinels
      Players can enter Conclave matches with improper Conclave ratings
          
      Unhelpful titles:
      Weird/Awesome/Gamebreaking Bug
      Uhhh, So This Happened...
      DE, This Bug Needs To Be Fixed NOW!!!!   Ensure that your bug report includes as many details as possible and that the report is made in the proper section. If possible, include any screenshots of the problem. If you know how the bug is reproduced, be sure to include that information as well.

      Thank you for helping us make Warframe the best game it can be! 
    • [DE]Danielle

      Getting Support - Common Issues   04/20/2016

      Have an issue? Unsure if we can help? Warframe's support team can assist you with the following common issues and concerns! 

      *Take care of reading through the instructions before sending in your Support ticket. An organized and detailed ticket will better help the agent answer and fulfill your request.* 
      "I accidentally purchased the same item twice."
      Before sending in a support ticket please choose which item you would like to keep and start using it! Support tries to have as little impact on your play time as possible; we're able to see which of the two items you aren't using and remove it from your inventory (even while you're logged in). 

      Please note: We will not perform refunds on items that have been used - Leveled items or items with any Affinity are not eligible for refunds. 


      "I accidentally purchased an item and would like a refund" 
      Platinum refunds can usually be processed, as long as you submit your request immediately after your purchase and the item has not been used. 


      "I sold an item by mistake, is there any way I can have it back?"
      Absolutely! In order to have the item restored please contact us as soon as possible after the sale - we have a limited window of time allocated to reversing this process.

      Please make sure you have an open Warframe / weapon slot for the item(s) you sold. Should you not have enough slots available at the time of the reversal, we will contact you to let you know that you need to make room in your inventory. 


      "I started building something in the Foundry that I didn't mean to."
      If the item is finished, please do not claim it. We cannot refund foundry items once they are claimed by the player. Unclaimed items will have the full construction costs refunded.


      "I purchased a skin, but I can't find it."
      Before sending in a support ticket, go to your Arsenal and browse for the purchased skin. You can search for and equip skins by clicking on the Appearance tab next to the item you want to customize.  If you experience difficulties, contact Support and we can verify that you have the item and further assist you with equipping it. 


      "My mod is missing" or "I fused a mod by accident!"
      Should you find you are missing any specific mod, please provide us with the name, rank, and the day you last saw the mod in your inventory. If you have an idea what mod it might have been fused into, please do not perform any more fusions; if a fused mod is fused again into a new mod, it cannot be recovered.
      "I accidentally used a Forma on an item!"
      If you accidentally polarized your item, please file a support ticket immediately and refrain from using the item in question until we get back to you.

      In the ticket, please specify the item that you applied the Forma to and what polarity you intended to add.    "I didn't receive my rewards from the event!"
      We kindly ask you repeat any events/missions if they are still available. Please keep in mind that we are unable to advance you towards the next step/level of the event (if there is one) and cannot change any end of mission scores. If you are still missing rewards after repeating, please wait until after the event has ended and the rewards have been given out. Once the event has concluded contact Support as soon as possible. 

      Since certain events have immediate rewards while others do not, please check our website / Forums / social media for any announcements about the distribution of event rewards.


      "My game crashed during a mission” or “My game was unable to update the account information and the progress was not saved.”
      Depending on the mission you played, try to re-join the session to receive your rewards. Please note that only the end of mission rewards (5 minute / round rewards) are recoverable. Pickups from the mission itself cannot be recovered by the support team.  If you are crashing or experiencing errors regularly, please create a support ticket in the most appropriate technical category so we can do our best to help you solve any networking / system problems you are experiencing. If possible, please also send your EE.log in a ticket immediately after the incident. EE.logs can be found in /%localappdata%/Warframe on your PC. 


      “I want to change my email address / delete my account”
      If you wish to update your account’s email address or have your account removed permanently, you will need to contact support and verify that you are the account creator.   “I have purchased Platinum/Prime Access, but have not received it yet”
      Usually purchases are applied to your account almost immediately, but depending on the payment method used (i.e. mobile payments) it can take up to 48 hours for your order to appear in-game.

      If you have not received your purchase after 48 hours, please create a ticket with the following information so that we can assist you as quickly as possible: Choice of payment service (Paypal, credit card, etc.) Date and time of payment Screenshots of the confirmation for the purchase, including the transaction/order number Mobile phone number used, if payment was made through mobile service Item purchased (Prime Access Package, 1000 Platinum bundle, etc.)   Experiencing issues that were not listed above? The following links are also at your disposal: Support’s Knowledge Base: https://digitalextremes.zendesk.com/hc/en-us  Trading Guide - FAQ, Tips, and Guidelines: https://forums.warframe.com/announcement/44-trading-guide-faq-tips-guidelines/   Got a problem? We can help you! Contact us here. 
    • [DE]Danielle

      [PC] THE PLAINS OF EIDOLON SUBFORUM   10/12/2017

      Since the Plains of Eidolon update on PC is massive we created a temporary subforum dedicated entirely to it.  If you are thinking of posting feedback on anything PoE related, please post here  and follow the Feedback Thread guidelines:  If you have a bug you’d like to report, please post in the appropriate categories:  General: Please post bug reports that do not fit into the other bug categories here! 
      Cetus/Plains: Please post bug reports pertaining only to the town of Cetus and the Plains of Eidolon here. 
      Focus 2.0/Operator: Please post bug reports pertaining only to Focus 2.0 and Operator Mode here! 
      "Saya's Vigil" Quest: Please post bug reports pertaining only to the "Saya's Vigil" Quest here! 

      Threads related to Plains of Eidolon content that are posted outside of this subforum, will be moved into the subforum by the Community Moderators. 

      THANK YOU!! 

Archived

This topic is now archived and is closed to further replies.

EmptyDevil

Urgent - Controller Power Menu Bug Has Returned

Recommended Posts

Confirmed I'm experiencing this issue as well - happens in or out of big picture mode, with Dualshock 4 connected to Steam link, or with wired xbox 360 controller

Share this post


Link to post
Share on other sites

Just tested it, I'm not encountering the problem again. I took Loki Prime out to a random mission just to test it, all of my powers worked as intended and the power menu closed. It may be more specific. What frames are you experiencing this on? Which powers? DE needs these sorts of details.

Share this post


Link to post
Share on other sites

It happens specifically with binding the power menu to LB instead of RB per the old bug thread, if I bind power menu back to RB it works fine.

Share this post


Link to post
Share on other sites

Just tested it, I'm not encountering the problem again. I took Loki Prime out to a random mission just to test it, all of my powers worked as intended and the power menu closed. It may be more specific. What frames are you experiencing this on? Which powers? DE needs these sorts of details.

 

It's in the link. I was using Loki Prime. It's exactly as jayekaiser said.

 

I just realized that link leads to a thread you made about the issue when it first popped up.

Share this post


Link to post
Share on other sites

So once again this bug returns. Y'all fixed it once already, I don't know what y'all did for it to return. but here is my old support ticket that explains my bug.

 

Fahren_Corvalis

Dec 8, 16:36

As of today, my power menu gets stuck and won't go away when ever I use any of my powers. My keybindings are unchanged since I made them the way they are when I started Warframe. The only change came when y'all added the 5th power(focus). That is up on the DPad for me. Now, when I use a power my power menu/wheel doesn't go away until I cast my 5, which for some reason is hold down LB(Power button), which never was keybinded that way before today. This problem is making the game unplayable for me as I can't run, jump, attack, revive, etc., as long as the power menu is up. Please help me or fix this problem. I am missing out on today's Sortie and other Alerts.

 

Share this post


Link to post
Share on other sites

Hey guys! Merged relevant threads here. The bug happens because the Power Menu is bound to LB, which is also default for the focus power (labelled as Power E). When this first came about we updated the code across all platforms so that it could detect and auto-fix the issue. It seems PC is experiencing some trouble with the change based on your reports, which we will be investigating tomorrow morning. 

 

For the time being, please go into your Customized Controller screen and bind "Power E" to something else. This will allow you to play the game until tomorrow when we can get a better look at what's happening. 

Share this post


Link to post
Share on other sites

Hey guys! Merged relevant threads here. The bug happens because the Power Menu is bound to LB, which is also default for the focus power (labelled as Power E). When this first came about we updated the code across all platforms so that it could detect and auto-fix the issue. It seems PC is experiencing some trouble with the change based on your reports, which we will be investigating tomorrow morning. 

 

For the time being, please go into your Customized Controller screen and bind "Power E" to something else. This will allow you to play the game until tomorrow when we can get a better look at what's happening. 

 

My "Power E" is mapped to D-Pad Up but the bug is still there. I will miss out on todays sortie, and my horrible chance to TRY to get Nezha.

Share this post


Link to post
Share on other sites

For the time being, please go into your Customized Controller screen and bind "Power E" to something else. This will allow you to play the game until tomorrow when we can get a better look at what's happening. 

 

My "Power E" has been set to "D-pad right" before the bug and it still breaks. 

Share this post


Link to post
Share on other sites

It's weird that I didn't experience this cropping back up. Extremely weird. Nothing about my setup has changed since I made the original thread. Well, I added some RAM to my machine but that's hardly going to make a difference. Very, very odd.

Share this post


Link to post
Share on other sites

Hey guys! Merged relevant threads here. The bug happens because the Power Menu is bound to LB, which is also default for the focus power (labelled as Power E). When this first came about we updated the code across all platforms so that it could detect and auto-fix the issue. It seems PC is experiencing some trouble with the change based on your reports, which we will be investigating tomorrow morning. 

 

For the time being, please go into your Customized Controller screen and bind "Power E" to something else. This will allow you to play the game until tomorrow when we can get a better look at what's happening. 

Mine is at d-pad down, it does not work at all, this is horribly annoying, the game is unplayable, this should be a priority not some thing you left for tomorrow smh... But ohwell at least the rb solution was fitting

Share this post


Link to post
Share on other sites

Well I toke my time writing a concise and professional post and then something happen my page reloaded and I lost it all. So here is a quick unprofessional version of what i found out and how to get the game working again. ahhh.... I hate myself right now.

 

I have found a work around to this Bug/Issue.

 

THIS WILL ONLY WORK FOR ONE GAME SESSION AT A TIME, SO SAVE A COPY OF THE ALTERED EE.CFG FILE.

What do i mean by this you ask? Well there is probably some pre-loader code set to alter some key bindings settings per the DEV's instruction. This is probably the "auto fix" Danielle mentioned.

 

Hey guys! Merged relevant threads here. The bug happens because the Power Menu is bound to LB, which is also default for the focus power (labelled as Power E). When this first came about we updated the code across all platforms so that it could detect and auto-fix the issue. It seems PC is experiencing some trouble with the change based on your reports, which we will be investigating tomorrow morning. 

 

For the time being, please go into your Customized Controller screen and bind "Power E" to something else. This will allow you to play the game until tomorrow when we can get a better look at what's happening. 

 

Knowing this I set out to break it. This means that this "fix" works per game session as the that piece of code will activate every time when the game is launched. Meaning every time you "Quit" the game and reopen it, it will happen again, but while in the game it will work no matter what mission your in and what key bindings you have.

 

TECH SAVY USERS SKIP TO STEP 5 AND COPY WITH THE CORRECT CFG FORMAT

 

Step 1. While in game change the config for Power E to D-PAD UP, or something you will remember then Quit out of the game.

 

Step 2. Go to " C:\Users\[uSER NAME]\AppData\Local\Warframe " WITHOUT THE QUOTES. Where [uSERNAME] is you logon name on your PC.

 

Step 3. Open EE.cfg with Note Pad.

 

Step 4. Find the string that says ACTIVATE_ABILITY_4={. In this case I have key=EN_GAMEPAD_UP bound to Power E which is Ability 4.

 

Step 5. Delete EN_GAMEPAD_UP from the key=EN_GAMEPAD_UP. DO NOT DELETE THE WHOLE STRING OR ELSE IT WILL NOT WORK. It should now look like this.

 

Original Config

ACTIVATE_ABILITY_4={
    {
        key=key=EN_GAMEPAD_UP
        inputMode=IM_NORMAL
        invert=0
        deadzone=0
        scale=1
        povAxis=PAT_UNUSED
    }
}

 

Broken Config

ACTIVATE_ABILITY_4={
    {
        key=
        inputMode=IM_NORMAL
        invert=0
        deadzone=0
        scale=1
        povAxis=PAT_UNUSED
    }
}

 

Step 6. Save the file and copy it to a separate location, like your Desktop, for use later.

 

Launch the game which will load properly but so things will be a bit different. When at the login screen some keys will act as the Esc key but don not worry as you can just hit NO when the gives up the "Are you sure you would like to exit the game" prompt and continue typing your password. The next change will be that your key bindings will be blank so most of your keys will do nothing. Setting your key bindings to what you desire will now work, but only for this session as I mentioned. All keys should now work with out issue including the LB/R1 bound as the Power Menu. If by the next time to want to Launch the game there has not been a patch to fix this Bug/Issue you will have to do this again.

 

Time for me to play now.....

Share this post


Link to post
Share on other sites

Yep. This is at least the 3rd time this bug appeared in the game. Using any ability, on any frame, causes the ability menu to stay open. While the ability menu is open you cannot run, roll, aim, shoot, use gear, or melee. All you can do is move and use abilities.

This wouldn't be so frustrating if it wasn't the 3rd time this bug had appeared, the 2nd time it was readded after being fixed. When you fix it this time, please also make sure it isn't automatically added to the game again during the next update, so you don't have to fix it again. Just sayin'.

Share this post


Link to post
Share on other sites

Hey guys! Merged relevant threads here. The bug happens because the Power Menu is bound to LB, which is also default for the focus power (labelled as Power E). When this first came about we updated the code across all platforms so that it could detect and auto-fix the issue. It seems PC is experiencing some trouble with the change based on your reports, which we will be investigating tomorrow morning. 

 

For the time being, please go into your Customized Controller screen and bind "Power E" to something else. This will allow you to play the game until tomorrow when we can get a better look at what's happening. 

 

I appreciate your suggestion, the only problem is that there aren't enough buttons on the controller to just map "E" to something else without removing another necessary command. There simply aren't enough buttons on controllers to do all that you need to do. Please consider adding a function to map commands to button combinations for controller players, instead of limiting it to single button presses only. It would go a long way towards alleviating problems like this and help gameplay in general.

Share this post


Link to post
Share on other sites

Hey all,

 

I'm looking into this issue and believe I'm getting closer to figuring out what's wrong. So far I have successfully reproduced the issue while not playing in Big Picture mode. In this case I was able to go into Options - Customize Controller, and rebind Power Menu to Left Bumper, after which going into a mission and pressing Left Bumper would trigger my Focus Power and cause the Power Menu to remain open, regardless of what Power E was bound to.

 

Without wanting to get too technical, the reason this is happening is because the game accepts a different type of input code when a button is pressed at the same time as the Power Menu. Currently, when you customize your controller bindings outside of Big Picure mode, we're not letting you customize those input codes, which I believe was merely an oversight on our part. Although you can currently customize Power A - E, those are just the regular shortcuts for use without the Power Menu. The result of all of this is that even if you've bound the regular shortcut for Power E to something else, the game still thinks Left Bumper should activate Power E if the Power Menu is open, and therein lies the problem. If Power Menu is also bound to Left Bumper, it gets stuck open.

 

I'm writing a fix right now that will allow you to properly customize those controller bindings that relate directly to use in conjunction with the Power Menu. I will also continue to investigate whether I can reproduce this issue while in Big Picture mode, since I see at least one post in this thread which suggests it is possible.

Share this post


Link to post
Share on other sites

I just logged in and can't play because of this bug. It gets painful and confusing to swap my power button to the RB, and I can only really use it on bumpers. My other bumper is melee, and melee needs to be spammed a lot more rapidly than powers(for me). For some reason, the left bumper gets painful for me when rapidly pressed, the right bumper not so much. I have tried many combinations, and only my current setup is comfortable to use. I have a disability that causes extreme sensitivity to stimuli, and constant pain. I play games to distract myself from the pain, and trying to workaround a system in a way that causes more pain is not worth it.

 

Please send me a PM when this issue is fixed, because I'm not going back in there when the only way to play is painful. 

Share this post


Link to post
Share on other sites

Hey all,

 

I'm looking into this issue and believe I'm getting closer to figuring out what's wrong. So far I have successfully reproduced the issue while not playing in Big Picture mode. In this case I was able to go into Options - Customize Controller, and rebind Power Menu to Left Bumper, after which going into a mission and pressing Left Bumper would trigger my Focus Power and cause the Power Menu to remain open, regardless of what Power E was bound to.

 

Without wanting to get too technical, the reason this is happening is because the game accepts a different type of input code when a button is pressed at the same time as the Power Menu. Currently, when you customize your controller bindings outside of Big Picure mode, we're not letting you customize those input codes, which I believe was merely an oversight on our part. Although you can currently customize Power A - E, those are just the regular shortcuts for use without the Power Menu. The result of all of this is that even if you've bound the regular shortcut for Power E to something else, the game still thinks Left Bumper should activate Power E if the Power Menu is open, and therein lies the problem. If Power Menu is also bound to Left Bumper, it gets stuck open.

 

I'm writing a fix right now that will allow you to properly customize those controller bindings that relate directly to use in conjunction with the Power Menu. I will also continue to investigate whether I can reproduce this issue while in Big Picture mode, since I see at least one post in this thread which suggests it is possible.

While you're fixing this serious bug any chance you could look into giving custom "Two button binds" for controller users. Figuring out some new combination of buttons for controller users to activate Focus powers, and implementing a better alt-fire for controller users- or even the opportunity to revert to the old right trigger shoot, left trigger, alt fire/ activate mode?

 

Being able to press multiple buttons for binds, would alleviate some issues for controller users. LB and RB for Focus power for example...

Share this post


Link to post
Share on other sites

While you're fixing this serious bug any chance you could look into giving custom "Two button binds" for controller users. Figuring out some new combination of buttons for controller users to activate Focus powers, and implementing a better alt-fire for controller users- or even the opportunity to revert to the old right trigger shoot, left trigger, alt fire/ activate mode?

 

Being able to press multiple buttons for binds, would alleviate some issues for controller users. LB and RB for Focus power for example...

That, and let us use Big Picture Mode, and have the binds that are available without Big Picture Mode. Having those options for binding is what makes me avoid Big Picture Mode. I hate having to do that, because the interface control is so much better. Sadly, missions are more important than the interface and menus. 

Share this post


Link to post
Share on other sites

So this bug is still live and unfixed. I have missed 2 days now for a chance to get Nezha. I bought a 7 day booster before this bug came back and now 2 days of it are gone and wasted cause I can't play the game. Would really like this fixed so I can play the game and use the booster I spent money on...

Share this post


Link to post
Share on other sites

We'll fix it in the morning... yeah im waiting

Yeah, they'll fix it in the morning, but didn't say the mrning of which day. Meanwhile we cant play. Maybe it´s time to look for another game to play

Share this post


Link to post
Share on other sites

Hey all,

 

Apologies for the wait. It appears that no new hotfixes went live yesterday, which is a little unusual. However I can tell you that my fix (described in my last post) is definitely in the next batch ready to go live and this is scheduled for release sometime later today.

 

In response to your post, Anihlmal, I know that in the past we've talked about how cool it would be to get one or more of the controller buttons acting like the Shift/Ctrl/Alt modifier keys on a keyboard, and how much extra functionality that would enable you to bind. Whether we're able to implement that in this version of our game engine is definitely something I'd like to investigate more thoroughly in the new year. I do also sympathise with the changes that happened to Alt Fire earlier this year. To provide some feedback on why they happened, it was essentially because in Parkour 2.0 we made it so that Aim also acted as cling to wall. However it was then realised that this would prevent Alt Fire from being used in such positions. The decision was made to detach Alt Fire from Aim, to re-enable that ability. However, and in my opinion, we should still have allowed binding of Alt Fire to the same button as Aim. Again, that is something I would like to revisit in the new year.

Share this post


Link to post
Share on other sites

Latest hotfix is out! Hopefully this means that you should now have the ability to rebind Power E (Power Menu) in your Customize Controller screen to something other than Left Bumper (or whichever button you currently use for Power Menu), and this should solve the issue of the Power Menu getting stuck open.

 

You might notice as well that I've also opened up the ability to rebind Powers A - D (Power Menu), which I figured I would do since there was no sense not to. However, please note that our UI elements aren't really flexible enough (yet!) to support properly displaying any rebound buttons for these actions, so if you choose to rebind those Powers please be advised that while they will work, the button icons on screen may be wrong! 

 

Thanks :)

Share this post


Link to post
Share on other sites

Latest hotfix is out! Hopefully this means that you should now have the ability to rebind Power E (Power Menu) in your Customize Controller screen to something other than Left Bumper (or whichever button you currently use for Power Menu), and this should solve the issue of the Power Menu getting stuck open.

 

You might notice as well that I've also opened up the ability to rebind Powers A - D (Power Menu), which I figured I would do since there was no sense not to. However, please note that our UI elements aren't really flexible enough (yet!) to support properly displaying any rebound buttons for these actions, so if you choose to rebind those Powers please be advised that while they will work, the button icons on screen may be wrong! 

 

Thanks :)

That's Great Jim! Opening up the power wheel for rebinding is great extra flexibility for controller users. I think it just needs cleaning up a little though, (I can handle the UI not currently supporting it).

 

Currently when you rebind "Power Wheel E (Focus Power)" to RB (Which is default quick melee, and melee attack in melee mode for me) it unbinds the button for the aforementioned melee uses. So whilst Focus powers work, you can no longer melee. 

 

So temporarily I've had to manually rebind "power wheel E" to an extra button I didn't really want to (Left on the dpad)- so have to press LB plus LEFT. I'm hoping you can fix that? I think melee is hard-coded into some of bindings  or can't be multi-binded currently? Reminds me of the Archwing up/ down stuff?

 

I was hoping I could have RB for quick melee and melee, and LB +RB for the Focus power- makes much sense to me.

 

Also you might want to default bind Power-wheel E to something, so then new players who plug in their controllers for the first time, aren't met with the frozen power wheel bug (which they will be, especially since they're new and have no idea what power E is or does, or that they have to rebind it to fix it).

 

As with regards to multi-button bindings and alt-fire. It's good to know you agree with me. I think it would make a much funner, easier to control game for everyone including those folks on the Consoles... I assume most of this stuff drips down to them too? And I assume they're struggling with alt-fire too? Will something already be implemented for their update 18 Focus power binding?

 

I absolutely understand why Alt-fire was given its own button, I agree with the decision. But think of how having the binding Left Trigger + RB for alt-fire (Left trigger acting as the modifier), or any other combination would allow people to use those guns much better... Currently I have to press right on the dpad- and that doesn't feel half as fun as the old, left-trigger, right trigger setup- and do I really need to aim with a grenade launcher?

 

I had a little play with the new snipers, and using right on my dpad to zoom, it severely cripples how effective those guns can otherwise be. Holding left trigger soft or hard to zoom further in perhaps? I don't know. 

 

Obviously I don't expect fixes tomorrow for all of these things, but some of these issues have been around for over half a year now. Be fantastic if it was shown a little care and attention next year! :)

 

Thanks Jim.

 

Edit: Oh yeah, currently my new favourite melee weapon has no vibration on the controller, "The Mios". Thought I'd add that in, since you got me that damn sweet fine vibration for the Dragon Nakana :p

Share this post


Link to post
Share on other sites