Jump to content
General Bug Report Guidelines - Please Read ×

Riven Mod Unveil Unable to complete -


indeed317
 Share

Recommended Posts

My 4th reroll on this quanta riven; and yes I'm using ivara stealth its equipped.  I've tried void sab caches, spy missions, grineer spy and sab and nothing.

When I link the mod it shows 5 caches but in foundry shows 4.  I'm out the endo used to upgrade it and the kuva for the numerous rerolls.  I've tried everything and I'm coming up empty.  Region has told me tons of tips but none have worked; I was even told to grab a cache and just extract...lol.  Nothing counts; even if the counter goes up it resets as soon as I do the sab part of the mission; there's no way for it NOT to raise alarm.  Even the one on earth where no alarm is present still resets.  :(

riven_zpspzxxlyqk.jpg

If anyone has had this veil stipulation and has actually got it to work what did you do exactly?  I've been struggling with this for 2 days now :(

Link to comment
Share on other sites

Ok FINALLY figured it out.

Earth - Cervantes

Get 2 of the caches - abort - do it again = complete.  

If you try to finish the mission the part with the poison will auto alert and you will lose the cache progress 

frustrating...but hey... the more you know 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...