Jump to content
General Bug Report Guidelines - Please Read ×

Glaxion weapon damage is broken.


MemeSageZ
 Share

Recommended Posts

So, my weapon [Glaxion] is supposed to have a base damage of 250 cold damage. but once i equipt it, it says 12 cold damage.... 12.... Freaking 12... before equiping, it shows 250, but after, it says 12. i can't kill anything with it, i have no mods installed on it. it's completely naked. yet, it has 12 based cold damage. i down Own a riven mod for it, but it's for +fire rate and +ammo max, and it's not even equiped. anyone else having this problem?

Link to comment
Share on other sites

Yeah, it's a bug and all, but, why are you surprised about how much damage (per second) you deal?

The Fire Rate was (incorrectly) shown as 1. Thus, 250 x 1 = 250 DPS.
The real Fire Rate is 20. So, 12.5 x 20 = 250 DPS. It's the exact same (bad) damage.

Sorry, just a bit annoyed over how many people simply don't understand how their weapons work :P

Link to comment
Share on other sites

5 hours ago, NinjaZeku said:

Yeah, it's a bug and all, but, why are you surprised about how much damage (per second) you deal?

The Fire Rate was (incorrectly) shown as 1. Thus, 250 x 1 = 250 DPS.
The real Fire Rate is 20. So, 12.5 x 20 = 250 DPS. It's the exact same (bad) damage.

Sorry, just a bit annoyed over how many people simply don't understand how their weapons work :P

haha...ha... I just got the Bloody weapon.. So no need to get annoyed. that's stupid. 

And it's the only weapon that does it. Litterally the only one. Quanta vandel doesn't have that "Bug" yet it has a damage per a second lazer just like the Glaxion. 

Why am i suprised? Because before i bought the weapon. the stats said "250 cold damage" and before i clicked "equip" it said 250 cold damage. and the second i click it, it says 12 cold damage. i unequip it, and it says 250 cold damage again. 

"Sorry just get a bit annoyed over how many people don't know how their weapons work" then Stop replying. 

Link to comment
Share on other sites

4 hours ago, Xiaoshino said:

And it's the only weapon that does it. Litterally the only one. Quanta vandel doesn't have that "Bug" yet it has a damage per a second lazer just like the Glaxion.

Quanta (Vandal or not) has a default Fire Rate of 1, so the bug that, pre-equip, sets every Beam weapon's Fire Rate to 1
and then adjusts the damage to retain the same DPS is just not visible there, pretty sure it's affected all the same.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...