Jump to content

Kuva Fortress Assault, telemetry key poofs if you pick more than 1 up.


Recommended Posts

During the part where you find and insert the 3 telemetry keys into the terminal.

Picking up a 2nd key from the floor while holding another removes it from existence.  Thinking I had 2 on me, putting it into the terminal only adds 1 and the mission is undoable from there.

Link to post
Share on other sites
  • 1 month later...

I am stuck at the door to let me into the area to get the 3rd key and the door is green. Ive done it all.../unstuck and then made the grinner lockdown and then tried to trick it and the door still wont open. Complete crap because it wasnt easy for me making it this far with just frost. 

Link to post
Share on other sites
  • 2 months later...

I just found this issue as well.

I was soloing the second node on the kuva fortress which is an assault mode. First time seeing one.

After reaching the part where we are to collect the 3 telemetry keys, I thought the keys could behave like the old datamasses and tried to pick 2 of them. However, having a key on hand and picking another from the floor will "fuse" both keys making the mission impossible to complete since we are short on one key while inserting them.

I guess the game just empties the whole hand regardless of how many we are carrying and puts both on the same keyhole.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...