Jump to content

Archived

This topic is now archived and is closed to further replies.

MimouAuditore

Launcher is stuck at checking for new content every time I update

Recommended Posts

Hello, this problem is very common for me, when I update the time I wait for the launcher to detect the new content size exceeds the required time to download the update, I try different things to make it work, like restarting the launcher, the pc, playing a different game while keeping warframe open (best method until now, seriously) those methods generally works but sometimes I wait for 1 hour or even more, which became annoying, and I never face this problem with other launchers of other games or even with "checking updates" part in warframe launcher, I really hope that you rework the launcher completely, and thnx for the hard work.

Share this post


Link to post
Share on other sites

I am also experiencing this issue. And, like MimouAuditore, it is very common for me also. I have not been able to get past the "Checking for new content" part, I've tried multiple things, such as un-checking Bulk download and the Aggressive thing (absolutely no change), restarting my laptop(no change), connecting to the internet via Ethernet cable(no change), rebooting my internet (no change), reading multiple forums, and getting on Minecraft (because for some odd reason that helps sometimes.) 

Most of the time it just tells me, "Update Failed! Some content updates could not be downloaded from our servers. Please restart warframe to try again. The update will be restarted shortly..." 

Share this post


Link to post
Share on other sites

Please fix this DE, this is horrible. My internet is great, but cant download a few mbs from the update? Its funny and frustrating at the same time. I tried uninstalling the game and reinstalling it, still didnt do anything. I'm really disappointed, such a great game, with this kind of bug, really really disappointing. Hope you guys can fix it soon

Share this post


Link to post
Share on other sites

Was working 7 hours ago and now it's stuck here and if I do verify cache it's stuck on that. Tried everything you can find by google and this is a problem from 2014 so why it's not fixed and comes back every other hotfix idk.

 

Anyone know if I can get a refund on my plat purchase because if I cant fix this then I want my money back as their is not point paying for something I can't play.

 

 

Share this post


Link to post
Share on other sites

Long time left the game for this same problem ... After a while I want to go back and I find that there is no solution ... I've been trying to play all day and the one I got is to download at 900b / s I did not even get to 1 kb / s ... The servers of the game hate the Latin American connection ..

 

 

 

Share this post


Link to post
Share on other sites

Ah, fun. Now my issue has evolved to an even LARGER problem. I had forgotten to try and verify my download cache, so like any normal person I clicked "Verify Download Cache."
Now the launcher freezes my laptop every time the "Verify Download Cache" status gets to 100%, and if I leave it like that it just stays like that. So i have to restart my laptop. I have done this MULTIPLE times. 
Does anyone know where the file that controls the "Verify Download Cache" thingy is? 

Share this post


Link to post
Share on other sites

also stuck at checking for new content. I never had a problem for 2-3 last updates. This problem pop up after the Glast Gambit 19.11 update. DE please fix this.

Share this post


Link to post
Share on other sites

it appears that the problem happened because of using a fast timeout so it never finishes checking the new content since it keeps retrying over and over again.

looks like an easy problem to solve but still no fix :(

Share this post


Link to post
Share on other sites

Well the timeout happens because data stops flowing between the server and the updater. Why the data stops, that is the question.

Share this post


Link to post
Share on other sites

do they make a change to the launcher after update 19.11 ? Never had any problems before. After the last Tennogen patch suddenly the launcher seems sensitive. Download speed reduced drastically and stuck at this checking for new content. I don't know if the problem lies within my connection or DE server. 

DE please read this thread and help us addressing the problem. Thanks

Share this post


Link to post
Share on other sites

I don't think it's a problem with our connections, it's an old bug and it's not fixed yet maybe because the launcher uses Internet Explorer script to work :facepalm::crylaugh:

Share this post


Link to post
Share on other sites

This is getting ridiculous DE, we all wanna play here, we spent so much time and money into this game. I really hope you fix this problem soon, all these hotfixes are pointless if there's a lot of players out there unable to play this game.

Share this post


Link to post
Share on other sites

I am having the same problem too. If you notice, the download speed for "Evolution Engine" in task manager is always very low. I am also having problem stuck at "checking for new content" almost every patch after "The Silver Grove" update in a slow connection. Also seem to be getting a lot of "Network not responding" too after the update. Did "The Silver Grove" update brought some unknown underlying network changes that are not documented?

Share this post


Link to post
Share on other sites

Same issue for me since yesterday launcher is "checking for new content".

Please fix this asap.

Can't even play during the weekend.  

 

Share this post


Link to post
Share on other sites

this is from february and they still havent done anything about it...

 

The game is good, But I think my mobile android games are more relyable... I will come back to playing angry birds... clash of clans...

They never failed me

Share this post


Link to post
Share on other sites

×
×
  • Create New...