Jump to content

Can't change key bindings


Recommended Posts

I have recently re-downloaded Warframe and now I can't change my key-bindings... When I go to change key bindings menu I change them, they stay changed I go back and confirm... When I approach an arsenal for example it says press E (instead of original X) to open but E does not work I still have to open with X... any help ?

Link to post
Share on other sites

Hey, I'm facing a related issue but different one. My changes to my key bindings work normally. Except for one. The 'hold to crouch' key. Before Update 20 I had it set to the key 'C'. After the update it still worked fine. But when I went to take a look at my keybindings, it reported the I left 'hold to crouch' unbound. When I went to set it back to 'C', it wouldn't work. I can set it to any other key except 'C' which is kind of frustrating since I already got that down to muscle memory for my crouch...

Link to post
Share on other sites

Hey, I found a temporary fix till the Devs patch it if you're interested.

I encountered the same problem as well, but I previously binded my 'C' key to 'Hold to crouch' and 'Descend(ArchWing)' and I ended up being unable to use it for crouch but still being able to bind it for the archwing controls. Thought to manually set it and googled how to do so, now it's working for me! I just avoid going into the keybindings screen again for fear it'll reset itself or bug out again. Here's how I did it, hope it works for you too:

*I recommend reading till step 6 before starting. If encountering any difficulties along the way to follow these steps. scroll further below and check the extensive section for solutions to issues I faced along the way.

1. Exit WarFrame if you're currently online. No need to close steam.

2. Go to C:\Users\(Computer Name)\AppData\Local\Warframe.

3. Open the EE.cfg file using notepad (doesn't have to be notepad++).

4. Press Ctrl+F and search for your desired control. Note: this might now work for certain controls as they could be named differently. In which case you'll have to either scroll through the list to find it with guesswork(it's pretty straightforward) by remembering what the control's current binding is.

5. You should be looking out for the phrase 'key=EN_blahblahblah' under the controls you're looking to alter. Replace blahblahblah with the letter 'C' so it looks like this: 'key=EN_C'

6. Save and exit. Start WarFrame.

 

Here's an extensive guide of what I did:

1. Go through steps 1 and 2. If you can't see AppData don't fret, just enter the directory manually. Clicking the folder icon beside the folder(it should be under the 'Home' or 'Share' button near the top) and it'll let you enter stuff manually. Copy 'C:\Users\(Computer Name)\AppData\Local\Warframe' and replace '(Computer Name)' with your computer's name. In my case it was something like C:\Users\Tom\AppData\Local\Warframe. That isn't the actual name of course HAHA! Oh, you can also just go to the 'This PC' folder or the frontmost folder and search for 'EE.cfg' though it may take quite awhile.

2. Opened the EE.cfg file with notepad++

3. USed Ctrl+F and searched for 'crouch'

4. Found 'CROUCH=' and 'HOLD_CROUCH='.

5. Figured 'HOLD_CROUCH=' is the one I wanted to change cos the 'key=EN_' was bound to the key I had to use temporarily.

6. Switched that key with the letter C in caps.

7. Saved changes. Reopened and checked that changes were saved.

8. Started WarFrame and had a moment of Euphoria.

9. Remembered some Tenno facing the same issues here. Came to share :)

 

Test it out and let me know if it helped you! :cool:

Link to post
Share on other sites
  • 3 months later...
On 3/27/2017 at 11:10 PM, UnknownGlory said:

Hey, I found a temporary fix till the Devs patch it if you're interested.

I encountered the same problem as well, but I previously binded my 'C' key to 'Hold to crouch' and 'Descend(ArchWing)' and I ended up being unable to use it for crouch but still being able to bind it for the archwing controls. Thought to manually set it and googled how to do so, now it's working for me! I just avoid going into the keybindings screen again for fear it'll reset itself or bug out again. Here's how I did it, hope it works for you too:

*I recommend reading till step 6 before starting. If encountering any difficulties along the way to follow these steps. scroll further below and check the extensive section for solutions to issues I faced along the way.

1. Exit WarFrame if you're currently online. No need to close steam.

2. Go to C:\Users\(Computer Name)\AppData\Local\Warframe.

3. Open the EE.cfg file using notepad (doesn't have to be notepad++).

4. Press Ctrl+F and search for your desired control. Note: this might now work for certain controls as they could be named differently. In which case you'll have to either scroll through the list to find it with guesswork(it's pretty straightforward) by remembering what the control's current binding is.

5. You should be looking out for the phrase 'key=EN_blahblahblah' under the controls you're looking to alter. Replace blahblahblah with the letter 'C' so it looks like this: 'key=EN_C'

6. Save and exit. Start WarFrame.

 

Here's an extensive guide of what I did:

1. Go through steps 1 and 2. If you can't see AppData don't fret, just enter the directory manually. Clicking the folder icon beside the folder(it should be under the 'Home' or 'Share' button near the top) and it'll let you enter stuff manually. Copy 'C:\Users\(Computer Name)\AppData\Local\Warframe' and replace '(Computer Name)' with your computer's name. In my case it was something like C:\Users\Tom\AppData\Local\Warframe. That isn't the actual name of course HAHA! Oh, you can also just go to the 'This PC' folder or the frontmost folder and search for 'EE.cfg' though it may take quite awhile.

2. Opened the EE.cfg file with notepad++

3. USed Ctrl+F and searched for 'crouch'

4. Found 'CROUCH=' and 'HOLD_CROUCH='.

5. Figured 'HOLD_CROUCH=' is the one I wanted to change cos the 'key=EN_' was bound to the key I had to use temporarily.

6. Switched that key with the letter C in caps.

7. Saved changes. Reopened and checked that changes were saved.

8. Started WarFrame and had a moment of Euphoria.

9. Remembered some Tenno facing the same issues here. Came to share :)

 

Test it out and let me know if it helped you! :cool:

Thank you. It worked.

Link to post
Share on other sites
  • 1 month later...

So i made this mistake and it resulted in basically what you were experiencing.

There are two "Customize Keybindings" menus. One is at the top of the options menu and one at the bottom. I was modifying the bottom one as i didnt see the one at the top. 

It resulted in the ingame text changing but the controls wouldnt change.

Hope this helps for those googling this problem. 

TLDR: ---TWO KEYBIND MENUS, USE THE TOP ONE NOT THE BOTTOM ONE-----

Link to post
Share on other sites
10 hours ago, Sojio said:

So i made this mistake and it resulted in basically what you were experiencing.

There are two "Customize Keybindings" menus. One is at the top of the options menu and one at the bottom. I was modifying the bottom one as i didnt see the one at the top. 

It resulted in the ingame text changing but the controls wouldnt change.

Hope this helps for those googling this problem. 

TLDR: ---TWO KEYBIND MENUS, USE THE TOP ONE NOT THE BOTTOM ONE-----

This worked for me, i feel stupid now xD
Thanks a lot tho
 

Link to post
Share on other sites
  • 1 month later...
On 3/26/2017 at 1:22 AM, UnknownGlory said:

Hey, I'm facing a related issue but different one. My changes to my key bindings work normally. Except for one. The 'hold to crouch' key. Before Update 20 I had it set to the key 'C'. After the update it still worked fine. But when I went to take a look at my keybindings, it reported the I left 'hold to crouch' unbound. When I went to set it back to 'C', it wouldn't work. I can set it to any other key except 'C' which is kind of frustrating since I already got that down to muscle memory for my crouch...

I have the exact same issue

 

Link to post
Share on other sites
  • 4 weeks later...
  • 1 month later...

I can't even change the keybindings in the first place. Usually in a game you would click in it then press the key you want to replace the previous keybind, but when I lick on it, it just sets it to "mouse button 5" which I'm not even clicking on the selection with >< what am I doing wrong? There's no instructions...

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...