Jump to content

Primary, Secondary, and Abilities are taking elemental combos from melee


Recommended Posts

While doing a mission on Uranus earlier, I noticed some VERY weird procs happening with my guns. My Dex Sybaris only has viral on it, but I was seeing corrosive and radiation somehow coming off of it.

NAldXIM.png

Dex Sybaris build aka proof of no corrosive (Riven has no elementals):

Spoiler

IsBagnJ.png

The same thing was happening with my secondary Pandero. It has corrosive and heat on it, but I was still seeing radiation procs.

0p3WX3u.png

Pandero build:

Spoiler

84Bdeua.png

I even saw radiation coming off of Octavia's MALLET. Suffice to say I was extremely confused, but after playing a bit I realized this was only happening when I had pure elemental damage melee equipped. The only time I noticed it was when I had my Dark Split Sword or Lacera with me, both of which had radiation on them.  It happens with every melee I have. I brought Galatine Prime and saw Mallet doing slash and corrosive procs:

Spoiler

kLaIBC6.png

Strangest of all, I can't reproduce this bug in the simulacrum. It only happens in missions, where everything dies too fast for me to tell if it's a visual bug or if the procs on my weapons actually change. After more testing, I can definitely say that this does actually change my damage into the wrong element.

Edited by Lluminate
Link to post
Share on other sites
27 minutes ago, OGPlebian said:

I don't see how this is a bad thing?

...you don't see how weapons doing the wrong procs is a bad thing?

If I have a status-based primary, then I want corrosive on it against grineer. If I'm proccing radiation instead, that's a problem and is directly affecting my damage output. Maybe I have a slash-proc build, like that niche build for the Soma, but all I'm getting are random elemental procs that I 1. don't want and 2. have not built for.

Not to mention that this is clearly a bug and should be fixed regardless of if we can find a way to exploit it or not.

Edited by Lluminate
Link to post
Share on other sites
On 3/30/2017 at 5:09 PM, Lluminate said:

...you don't see how weapons doing the wrong procs is a bad thing?

If I have a status-based primary, then I want corrosive on it against grineer. If I'm proccing radiation instead, that's a problem and is directly affecting my damage output. Maybe I have a slash-proc build, like that niche build for the Soma, but all I'm getting are random elemental procs that I 1. don't want and 2. have not built for.

Not to mention that this is clearly a bug and should be fixed regardless of if we can find a way to exploit it or not.

 

On 3/30/2017 at 5:57 PM, Timythedarkside said:

my mind would go nuts

 

Don't mind me being $&*&*#(%& and not reading the thread title yeah if it's procing the wrong weapon's damage i'd kms imagine fighting sentients lmaoo

Link to post
Share on other sites
  • 3 weeks later...

Speaking of bugs in Uranus since update 20, I've been having issues with my minimap not working right after exiting the water from Archwing mode, and I've also been having issues with my character being pushed back randomly by some invisible wall, forcing me to have to either jump or bullet jump just to be able to go forward. I don't know if I'm the only one experiencing this problem, but please let me know if any of you have this same issue.

Link to post
Share on other sites
8 hours ago, Sm0kiT said:

Happens to me all the time since around U20. Was wondering why nobody else was experiencing this.

yeah, happens to me all the time also after U20. It seems to happen to clients only as well. I see it all the time when playing LOR. I read somewhere that it might be related to having rivens equipped. Next time I do LOR I wont take any rivens and see if problem persists.

Link to post
Share on other sites
On 4/27/2017 at 8:00 AM, gamer55567 said:

Speaking of bugs in Uranus since update 20, I've been having issues with my minimap not working right after exiting the water from Archwing mode, and I've also been having issues with my character being pushed back randomly by some invisible wall, forcing me to have to either jump or bullet jump just to be able to go forward. I don't know if I'm the only one experiencing this problem, but please let me know if any of you have this same issue.

You're not the only one. DE knows about it. It's related to melee on the Uranus tile set, I believe they're working on a fix already.

 

On 4/27/2017 at 11:17 AM, (PS4)leduanjohan said:

yeah, happens to me all the time also after U20. It seems to happen to clients only as well. I see it all the time when playing LOR. I read somewhere that it might be related to having rivens equipped. Next time I do LOR I wont take any rivens and see if problem persists.

It can't just be rivens. I don't have a riven for my Pandero, and it was still happening with mallet and galatine. :/

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...