[DE]Glen

W10 Creators Update and Mouse Buttons

Recommended Posts

After uploading Microsoft's Creator Update, Warframe stopped recognizing the mouse 4 & 5 buttons. This issue is apparently being experienced in other games.

Reverting to "DEFAULTS" keybindings fixed the issue for me. Thank you GuruLou!!! :satisfied:

Share this post


Link to post
Share on other sites

I have a cheap gaming mouse A4Tech X-710 with broken button ( pressed too hard ) and that's the only issue I have  , no other problems with Windows 10 CU . Soon coming another major Windows 10 update that bring more changes

Share this post


Link to post
Share on other sites

This bug seems to be related to the Windows 10 creator update. Going into the device manager and disabling the HID compliant mouse and all other mice except for the one you are using seems to fix the issue. Time will tell if it stays that way. Good Hunting Tenno!

  • Upvote 2

Share this post


Link to post
Share on other sites

Thank you allmighty Tennos, disabling HID's in the Device Manager fixed my Problem too. Didnt even have to unplug or use another USB-Port. Just deactivated some Things and viola, there it is again *_*

Picture of what i deactivated:

works_againkmstk.jpg

 

Slight Edit\\ Had to reboot after the changes to make Mouse 4 work again and get acknowledged in Warframe - But works again now

Edited by tischkanteVS

Share this post


Link to post
Share on other sites

Device Manager fix worked for me.
I have a Razer Mamba 5-button mouse and a Razer Nostromo keypad.  Opened up device manager, and both devices were under "Mice and other pointing devices."

 > Disabled the Nostromo, opened up the MouseTest, 5-buttons detected.
 > Closed the MouseTest, re-enabled the Nostromo, opened up the MouseTest again, 5-buttons detected, still.
> Opened Warframe, and all 5 buttons work.

Share this post


Link to post
Share on other sites

Greetings my fellow Tenno!

Had the Creators Update, had the mouse breakage, and had to work out my own fix, since none of the those listed here worked for me.

In my case, my Razor Ouroboros mouse and my Razor Blackwidow keyboard were both listed under both Mouse/other pointers AND under Keyboards on the Device manager.  I simply clicked the uninstall option on the hardware that was in the wrong category and every thing worked fine after that.

Share this post


Link to post
Share on other sites

I have solved my problem with the mouse 4 and mouse 5 buttons by Going into device manager ( Right Click on My Computer->Manage->Device Manager or going into My computer folder and click on Manage on the upper part of the folder) and uninstalling any devices from the mouse tab, except for your mouse( my  mouse was listed as "HID compliant mouse"), I had Razer BlackWidow (keyboard product) in the mouse tab and after i uninstalled it and restarted the pc, it worked fine. I believe it has something to do with the order of which one goes first when booting Windows up.

I haven't done any of the power functions like the fast boot, or going through bios changing things (although i checked the options) and so on. 

Good Luck!

Edited by RobyMeth07
  • Upvote 1

Share this post


Link to post
Share on other sites

The unplugging statement is true. Before when the mouse functions where working if i unplugged my mouse and plugged it back in, the 4 and 5 would no longer register and game had to be restarted. Now they never respond no-matter how much i plug and unplug or restart the game.
Also I have tried external programs that change the mouse buttons signal to activate other keys and set those keys to the hot keys but when in game the 4 and 5 keys do not activate the new keys like they did outside of game.

I have tried all the work rounds and nothing seems to work.
-setting everything to default and starting again, does not work at all.
-disabling all mice, this one is hard because you cant disable the trackpad from device manager only uninstall and i dont want to risk that (i do use the disable trackpad hotkey though but no luck in detecting 4,5 on my good mouse no matter how many uninstalls and replugs i do with it).
-disabling HID, this one is also hard as i have only 3 and none of which they are not ones shown in the picture. I tried disabling all 3 some need restarts, didnt seem to work.
TBH experimenting with device manager, uninstalling ect... doesnt seem wise to me as i dont entirly know what im doing and dont want to remove something I need to keep the thing running I.E. loosing the ability to use any kind of mouse is hell to re-enable and what if its something like display...
Looking for a direct solution please. Keep at it DE when you find the answer to the meaning of life ;) ill come back to warframe.
On another note when this happened my other games seemed to have lost their key binding hotkeys for 4,5. however all that was needed was rebinding, maybe they found a way to work round the key 4,5 keys not registering. (do you have any friends working at blizzard you can ask? or even Microsoft as it would be a known issue?).

Edited by Pitiful

Share this post


Link to post
Share on other sites
On 5/28/2017 at 9:44 AM, RobyMeth07 said:

I have solved my problem with the mouse 4 and mouse 5 buttons by Going into device manager ( Right Click on My Computer->Manage->Device Manager or going into My computer folder and click on Manage on the upper part of the folder) and uninstalling any devices from the mouse tab, except for your mouse( my  mouse was listed as "HID compliant mouse"), I had Razer BlackWidow (keyboard product) in the mouse tab and after i uninstalled it and restarted the pc, it worked fine. I believe it has something to do with the order of which one goes first when booting Windows up.

I haven't done any of the power functions like the fast boot, or going through bios changing things (although i checked the options) and so on. 

Good Luck!

Yeah I can confirm this, last week I turned on show hidden devices and saw like 5 mice. I uninstalled all those and windows has been detecting mouse 4 and 5 fine ever since.

 

Share this post


Link to post
Share on other sites

Having same issue, works on chrome etc but not in game. The mouse test doesn't detect them either. I followed someone that said "restoring bindings to default fixed for me" though it didn't fix it plus I have to wait for fix to be added to re-add all my hotkeys ;_;

Share this post


Link to post
Share on other sites

Just dropping this because i'm not sure if it helps or not. 

On a desktop with all latest drivers, got the win10 creators update and a razer 2013 (i think) death adder. Got no issues with mouse 4-5.

Share this post


Link to post
Share on other sites
On 21.5.2017 at 7:32 PM, Tex_Tenno said:

This bug seems to be related to the Windows 10 creator update. Going into the device manager and disabling the HID compliant mouse and all other mice except for the one you are using seems to fix the issue. Time will tell if it stays that way. Good Hunting Tenno!

that fixed the problem for me too! thanks a lot :)

Share this post


Link to post
Share on other sites
On 5/8/2017 at 7:04 PM, JellyKuo said:

I solved mine by doing the following

1. Download the mouse test tool above

2. Remove all mouse except the one you have trouble with

3. Open device manager, in the mouse section if you see two mice, disable one

4. If your mouse stopped working, re-enable it using keyboard or replugging

5. Disable the one which won't freeze your mouse

6. Restart the test tool, it should now properly detect it as a 5-button mouse

This is what lead me to fix mine. I have a Razer DeathAdder

Share this post


Link to post
Share on other sites
On 6/6/2017 at 1:01 PM, Raptor_ODonnell said:

This is what lead me to fix mine. I have a Razer DeathAdder

So after fixing it reverted itself, forcing me to have to re-apply my fix.
Namely, if you're a person with multiple Razer devices and use Razer Synapse, this will probably help you specifically.

It seems that warframe and/or Windows locks what it considers the "Main mouse" even after unplugging and replugging in a mouse. In the device manager, my Tartarus[gamingpad], DeathAdde[mouse]r, and BlackWidow[keyboard] all show up in "mouse" category.

So from:
 

Spoiler

lI6P1TV.png

 

To:

Spoiler


Eyk0wzb.png

At the log in screen, if you have the "use mouse button as back key" enabled, you can typically test the fix before actually logging in, as doing so will bring up a prompt to exit warframe.

All in all, I'm reconfirming what people have stated previously, which is to make sure that the ONLY active mouse ONCE STARTING Warframe is the one with the mouse buttons.
I've had occasions where I can turn Warframe off and jump back on and it works, but this only seems to be the case as long as my computer hasn't gone into sleep mode, been restarted, or at the very least, hasn't been sitting for a long period of time.

This might also save people from a frustrating cycle of restarting their computer and it doing nothing, as I don't bother restarting this way.

Edited by Raptor_ODonnell

Share this post


Link to post
Share on other sites
10 hours ago, Raptor_ODonnell said:

So after fixing it reverted itself, forcing me to have to re-apply my fix.
Namely, if you're a person with multiple Razer devices and use Razer Synapse, this will probably help you specifically.

It seems that warframe and/or Windows locks what it considers the "Main mouse" even after unplugging and replugging in a mouse. In the device manager, my Tartarus[gamingpad], DeathAdde[mouse]r, and BlackWidow[keyboard] all show up in "mouse" category.

So from:
 

  Hide contents

lI6P1TV.png

 

To:

  Reveal hidden contents


Eyk0wzb.png

At the log in screen, if you have the "use mouse button as back key" enabled, you can typically test the fix before actually logging in, as doing so will bring up a prompt to exit warframe.

All in all, I'm reconfirming what people have stated previously, which is to make sure that the ONLY active mouse ONCE STARTING Warframe is the one with the mouse buttons.
I've had occasions where I can turn Warframe off and jump back on and it works, but this only seems to be the case as long as my computer hasn't gone into sleep mode, been restarted, or at the very least, hasn't been sitting for a long period of time.

This might also save people from a frustrating cycle of restarting their computer and it doing nothing, as I don't bother restarting this way.

Whats the fix ?

 

edit :

 

Oh ok I get it now. 

I did the same thing and I passed the mouse test. Haven't tested the game yet but I think it will work. Thanks a bunch.

Edited by White_Matter

Share this post


Link to post
Share on other sites

My solution was to rebind the buttons to keyboard keys i dont use and setup a profile in my mouse software that enables for specific games i need it.

 

I.E (may have mixed up which one is which mb)

MB 4 to num pad * 

MB 5 to Num pad /

 

Been doing fine since

Screenshot%2026_zpsxxrqz3od.png

Edited by Echoa

Share this post


Link to post
Share on other sites

I just got this problem last week. I've tried a few of the things listed in the thread but not working.

I only have 1 mouse and it's labeled as HID compliant mouse in device manager, nothing else there.

Share this post


Link to post
Share on other sites

Good that the devs are aware of the issue... I've waited until the 5th before I've upgraded to the creators update just to give Microsoft time to fix bugs... seems like I didn't wait long enough...

Anyway, @JellyKuo workaround seems to work fine ;) My mouse is once again detected as a 8 button mouse.
Btw. I'm not using a Laptop, never used fast-boot (don't like the idea behind it and that it writes to my SSD everytime I shutdown my PC)
My 2nd mouse seems to be my PS/2 (mouse/keyboard combi) port and Windows seems to either use the first driver it finds or uses the one with the fewest buttons since the Creators update... Well since I don't need that port or even a 2nd mouse, disabling it isn't an issue for me.

Share this post


Link to post
Share on other sites

 

Disabling Mouse HID's in the Device Manager fixed mine.  I had previously tried uninstalling driver and restarting but no change.  Thanks for the tip :)

Share this post


Link to post
Share on other sites

Damn, no sollution yet =(

Is there a way to make WF use raw input like some other games do? Cause DirectInput (test) detects my thouchpad (3 button mouse lul) first or smth and i can make it work only by uninstalling touchpad drivers, but still its working for the next reboot only. 

(Any laptop user resolved this at all?)

Edited by MrAlt

Share this post


Link to post
Share on other sites
On 09.05.2017 at 2:04 AM, JellyKuo said:

I solved mine by doing the following

1. Download the mouse test tool above

2. Remove all mouse except the one you have trouble with

3. Open device manager, in the mouse section if you see two mice, disable one

4. If your mouse stopped working, re-enable it using keyboard or replugging

5. Disable the one which won't freeze your mouse

6. Restart the test tool, it should now properly detect it as a 5-button mouse

Thnak You, JellyKuo!

Worked for me!

You are my lifesavior xD

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now