[DE]Glen

W10 Creators Update and Mouse Buttons

Recommended Posts

It has come to our attention that Windows 10 Creators Update may be having problems with some mice; the system gets into a state where the mouse looks like it only has 3 buttons and your bindings for Button 4, 5, etc stop working.

This seems to have started with the Creators Update -- systems on Windows 10 Anniversary Update seem to be fine -- and it may be isolated to laptops but we're not sure.

This isn't just Warframe: Google turned up lots of confused players having problems with other games. We even adapted a trivial DirectInput sample app that reproduces the problem (which is helpful for testing workarounds!). You can try the test yourself here:

http://content.warframe.com/forums/MouseTest.zip

Both 32 and 64-bit versions are included just in case this matters. When Windows has been mixed up it'll report that your mouse only has 3 buttons and will ignore the extra buttons in the test.

This mystery was particularly confusing because these buttons would continue to work in other programs (not games). For example Button 4 would still perform a "Back" command in a web browser.

The first clue we found was that it seems to be related to unplugging: it would work fine but then after the mouse was reconnected games would see it as only a generic 3-button mouse. This would reproduce the problem for one player every time but when we tried this ourselves we couldn't get it to break; it's possible that this only occurs when the system is a laptop and unplugging the mouse toggles back to a generic touchpad but we're not sure.

The only workaround we have heard of so far is just to reboot Windows -- however one user reported that this only fixed it if his mouse was plugged into certain USB ports.

Another claim was that you have to turn off "Fast Startup" -- we could not verify this workaround so it may not be true. If you want to try it anyway the steps are roughly:

Spoiler

 

This only applies if you have Hibernation enabled (typically on laptops). Go to your Control Panel, under Power Options:

rfw1mxS.png

You may need to click "Change Settings that are currently unavailable" in order to expose the Fast Startup option in order to deselect it.

Once you've turned it off you'll need to shut your PC down completely and then boot it up again (a restart may not work!).

 

We're still investigating at our end but so far we have no leads; if you have clues or workarounds we'd love to hear about it!. 

Special thanks to @Crackle2012 and @Tenarsha for assisting with the initial investigation!
 

  • Upvote 34

Share this post


Link to post
Share on other sites
Posted (edited)

:thinking: <- This doesn't look like a thinking face.

Edited by Asphyxxia
  • Upvote 6

Share this post


Link to post
Share on other sites

Very useful information, thanks for sharing DE Glen.

Share this post


Link to post
Share on other sites
Posted (edited)

I am on a desktop and I can 100% confirm that this is a problem for me. I'm using a Razer Deathadder 2013. I'll do some other testing to see if any of those workarounds works. I'll let yal know

Test results:

Spoiler

 

Changing fast startup in my bios does nothing

Tried plugging in my mouse to USB 2 instead of USB 3, no change

In games where my Mouse 4 and 5 buttons work (I tested CSGO and Rainbows 6 siege), unplugging and replugging it back in doesn't make it stop working

Rebooting Windows with the mouse plugged into a USB2 Port seems to fix the issue, even unplugging and plugging it back in doesn't affect it. Confirmed working in game aswell. You can even move the mouse back to a USB 3 port afterwards and it will still work.

Just restarted my pc again with the mouse back in the USB3 port and now it's still working?

 

After that one restart where I swapped the mouse to a USB2 port it seems to work no matter what I do, Which is strange. I Even just did a complete shutdown and started the computer back up with the mouse in the USB3 port and it still works. Honestly really lost here. Maybe windows did something weird and you just need to restart with it in a USB 2 port once? It might even be down to some other random factor I don't know about. BUT, it works now so I'm not gonna ask any questions lol

Edited by Zenviscerator
here
  • Upvote 3

Share this post


Link to post
Share on other sites

Thanks for the info!

While we're on the topic of the Creators update, PhysX particles don't seem to be working with the update either (last time I checked). It would be awesome if this were fixed as well!

Share this post


Link to post
Share on other sites
1 minute ago, SortaRandom said:

Thanks for the info!

While we're on the topic of the Creators update, PhysX particles don't seem to be working with the update either (last time I checked). It would be awesome if this were fixed as well!

Did you get the latest drivers as per this?

 

  • Upvote 3

Share this post


Link to post
Share on other sites

Awesome, thanks so much for looking into this Glen! :-)

Also, @SortaRandom definitely check your Graphics Drivers, because I'm having the mouse issue, but my PhysX are just fine with Creator update.  :-)  Hope this helps!

Share this post


Link to post
Share on other sites
Posted (edited)

One thing that I have noticed since updating to the creators update is that my touchpad on my laptop got considerably more sensitive to touch, and considerably more annoying (ASUS ROG GL552-VW). I'm using a Corsair M65 RGB (non-pro edition).

 

Edit: After testing the mouse checking package provided by [DE]Glen, I can confirm that Windows does not recognize that there are 5 buttons on my mouse. However, Planetside 2 recognizes that my mouse does have 5 buttons

Edited by rc1309
Providing further information

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks glen. I will be sure to test the mouse test.

Edited by --Q--Voltage
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

I updated to the Creator Update today and my mouse seems to be working fine. On a Desktop, so may be a Laptop issue as suspected. Mouse is a Naga. All Thumbkeys working. I never use MB4 and MB5, but tested them and seem to be working, at least when I went to Keybind them to something in game.

Edited by Ceryk

Share this post


Link to post
Share on other sites

Reminds me.of when Microsoft did the Anniversary Update and Exclusive Mode changed, thus some DInput to XInput programs stopped working completely.

 

Microsoft and their weird changes :')

 

Thanks for the work Glenn :)

Share this post


Link to post
Share on other sites

Well for me my Windows seems to detect that my mouse has more than 3 buttons no problem and I have the creator's update, and I'm running off a laptop myself.

 

In any event I do hope those with this problem can find a fix or an official fix for this problem comes around.

Share this post


Link to post
Share on other sites

Running Windows 7 64-bit with Logitech G502. Not a problem here since a year ago when warframe.x64.exe started rejecting mouse config profile, solved by locking (persistent) profile. :>

Share this post


Link to post
Share on other sites
28 minutes ago, ntyd1s said:

Running Windows 7 64-bit with Logitech G502. Not a problem here since a year ago when warframe.x64.exe started rejecting mouse config profile, solved by locking (persistent) profile. :>

 

Yeah well the thread says W10 for a reason.

  • Upvote 6

Share this post


Link to post
Share on other sites
Posted (edited)

I have this problem on my Desktop so it is not limited to laptops. I have gotten the buttons to work once (in warframe) since I updated windows but since that one time they stopped working. Not sure what I did that one time. I never unplug my mouse's usb.

 

Logitech G602 Mouse

 

Update

Ok well for me I went into Device manger and uninstalled one of the mice listed (I had two listed only one real one) and now it seems to detect all my mouse buttons. Even after a couple reboots.  The one I uninstalled did come back in device manager. 

Will see if it stays that way.

 

Update 2

Well just now mouse 4 and 5 decided stopped working again, however uninstalling my mouse driver again made it work.

Edited by Cyberblaster
update 2
  • Upvote 5

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/2/2017 at 4:00 PM, [DE]Glen said:

Did you get the latest drivers as per this?

 

 

On 5/2/2017 at 4:47 PM, (PS4)Crackle2012 said:

Awesome, thanks so much for looking into this Glen! :-)

Also, @SortaRandom definitely check your Graphics Drivers, because I'm having the mouse issue, but my PhysX are just fine with Creator update.  :-)  Hope this helps!

That update had fixed PhysX particles not working for me (since PhysX particles were re-enabled in that update for newer graphics drivers, of course), but then I downloaded the Creators update about a week later and PhysX apparently broke again. I'm away from my computer right now, so I can't check and be completely sure, but I think I had updated my drivers to 381.65 before applying the Creators update. Might just be my memory tricking me, though.

Sorry I couldn't provide more information! :(

Edited by SortaRandom

Share this post


Link to post
Share on other sites

I solved mine by doing the following

1. Download the mouse test tool above

2. Remove all mouse except the one you have trouble with

3. Open device manager, in the mouse section if you see two mice, disable one

4. If your mouse stopped working, re-enable it using keyboard or replugging

5. Disable the one which won't freeze your mouse

6. Restart the test tool, it should now properly detect it as a 5-button mouse

  • Upvote 5

Share this post


Link to post
Share on other sites
On 5/4/2017 at 2:02 AM, SortaRandom said:

 

That update had fixed PhysX particles not working for me (since PhysX particles were re-enabled in that update for newer graphics drivers, of course), but then I downloaded the Creators update about a week later and PhysX apparently broke again. I'm away from my computer right now, so I can't check and be completely sure, but I think I had updated my drivers to 381.65 before applying the Creators update. Might just be my memory tricking me, though.

Sorry I couldn't provide more information! :(

No worries!  
This may seem super obvious, but I just want to make sure that you have checked and this is actually turned "on" in your in-game settings?  
ctYXRuy.jpg


If it is indeed on, then are you just not seeing any PhysX?  Or Is the option greyed out for you completely?

Share this post


Link to post
Share on other sites
4 hours ago, JellyKuo said:

I solved mine by doing the following

1. Download the mouse test tool above

2. Remove all mouse except the one you have trouble with

3. Open device manager, in the mouse section if you see two mice, disable one

4. If your mouse stopped working, re-enable it using keyboard or replugging

5. Disable the one which won't freeze your mouse

6. Restart the test tool, it should now properly detect it as a 5-button mouse

I will definitely see if this helps.  I had tried disabling my touchpad via the "Function + F9 Key" on my laptop, but I didn't try disabling it from the device manager.  

Whether it helps me or not, I am glad that it solved the issue for you! :-) -  & thank you kindly for the information!  

Share this post


Link to post
Share on other sites
On 03/05/2017 at 7:53 PM, Cyberblaster said:

I have this problem on my Desktop so it is not limited to laptops. I have gotten the buttons to work once (in warframe) since I updated windows but since that one time they stopped working. Not sure what I did that one time. I never unplug my mouse's usb.

 

Logitech G602 Mouse

 

Update

Ok well for me I went into Device manger and uninstalled one of the mice listed (I had two listed only one real one) and now it seems to detect all my mouse buttons. Even after a couple reboots.  The one I uninstalled did come back in device manager. 

Will see if it stays that way.

 

Update 2

Well just now mouse 4 and 5 decided stopped working again, however uninstalling my mouse driver again made it work.

I can vouch for uninstalling the "fake" mouse in Device Manager working. For the time being, at least.

 

Fore reference, I'm using a Zowie ZA11.

Share this post


Link to post
Share on other sites

The creators update managed to mess with my wireless services... I've got less connection now than I did before. Thanks Microsoft!

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/9/2017 at 11:21 AM, (PS4)Crackle2012 said:

No worries!  
This may seem super obvious, but I just want to make sure that you have checked and this is actually turned "on" in your in-game settings?  



If it is indeed on, then are you just not seeing any PhysX?  Or Is the option greyed out for you completely?

Sorry about the delay!
The option was greyed out for me completely, sadly. This was with 64-bit mode, if that helps.

I'm not going to be reunited with my computer for a little over a month, though, so I won't be able to test out any fixes for quite a while. Sorry! :(

Edited by SortaRandom

Share this post


Link to post
Share on other sites

uugh .. how did MS miss the fact that Mouse 4 and 5 weren't in their new release ?

Time to re-install the Steel Series drivers ..

 

Share this post


Link to post
Share on other sites

I run a Logitech G300s.  I tried plugging the mouse into a different port without restarting anything. No dice.

 

I rebind many of my keys.  Hitting "Default" fixed the problem.  I rebound my keys with no problem.

 

Yes, I admit this baffling. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now