Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Glaive Issue


Recommended Posts

So I was playing the other day, and somehow at one point in the mission I was unable to use any melee attacks. I tried switching between rifle and pistol but I was unable to use the Glaive for a while. Getting knocked down by an enemy actaully fixed it so it might be animation related or something. Only happened the one time, kind of a strange bug honestly.

Link to comment
Share on other sites

Known bug. Some powers and/or getting knocked down keep you from being able to use ANY melee weapon.


Sometimes changing primary to secondary weapon and reloading a few times fixes it. Sometimes using another power does. Sometimes getting knocked down again does.


Sometimes not. It IS very annoying when it happens. Especially when I am leveling a new melee weapon.

Edited by Kalenath
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...