Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Orokin Void Elevator Glitch - No Way Out


Recommended Posts



The issue here isn't that the doors aren't opening. It's the fact that, for some reason, the "top" part of the elevator (where I'm looking at) is made so that it will "reset" you the same way that it does when you fall into a bottomless pit. Since I have to take the elevator UP in order to continue the mission, it will constantly teleport/reset me back DOWN where I came from. There was no other way to go around it.


I tried Nova's wormhole, my fellow ally tried his Loki's decoy + switch teleport. None of these work against the "reset." We were forced to leave the mission.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...