Jump to content
Echoes of Duviri: Share Bug Reports and Feedback Here! ×
  • 0

Clan Emblem Is Not What I Uploaded


Edgy
 Share

Question

So I uploaded a CE and waited for approval. Today I see it was approved (probably a few days ago), but the CE is the default Lotus. 

Was it actually approved?

Takes more time to actually show up?

I don't know. Not too worried if the CE showed up all garbled because of the image I used, since I did it before any of us really knew all the 'fine print' of how it would look depending on the image. Haven't seen a thread on this and to be honest I barely have enough time to play let alone read through ALL the post that may hint to what I'm looking for. If you can point me in the right direction or just shed some light on it that'd be cool.

 (if it went so costly i'd just screw with it till i figured it out)

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

I relogged. A few days later, still the same old Lotus symbol.

To be more descriptive... in case you only relogged, you have to actually close Warframe completely with the warframe you want the emblem on equipped. That fixed it for me on all my warframes

Link to comment
Share on other sites

I had completely closed out WF a few times after it was accepted and it didn't change so I wrote this. I have probably quit WF and restarted 7-8 times over the last 50 minutes and even closed Steam (i know has nothing to do with it) a few times and didn't do anything till this very last one. 

 Conclusion, just keep checking on it by completely closing WF now and then and it will pop up. Steam I'm sure has nothing to do with it, I was just frustrated.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...