Jump to content
General Bug Report Guidelines - Please Read ×

The Great Eidolon Hunt Achievement Bug


(XBOX)Static Rainn
 Share

Recommended Posts

There seems to be an issue with getting this achievement, I first encountered it when my friends and I went to kill our first eidolon. I was the host and all 3 of them got the achievement but me. The second time we tried having another person host to see if that would resolve it but still no achievement. The third time my friends let me do all the damage in the final stage and get the killing blow and that didn't work either. The only thing left that I haven't tried yet is soloing a eidolon but I feel like I've already got the achievement but its just not unlocking even after a hard reset on my xbox. This should be able to be resolved in a hot fix / update.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...