Archived

This topic is now archived and is closed to further replies.

RugerMK1

FPS dropping in Orokin/Plains

Recommended Posts

Running a Nvidia GTX 970, on the ship my FPS are fine but in the Orokin Void tileset or the Plains/Cetus I get severe FPS drops. FPS goes from holding at 70 to 30s in the Void, in the Plains the drop is even worse down to 18FPS.  I was getting this FPS drop with older Nvidia drivers from Nov/Dec/Jan before updating to February's drivers which did not resolve the issue.

Oddly enough, I am able to play on the Kuva Fortress tileset just fine. 70 FPS during a testing mobile defense.  I  tried turning off DirectX 10 in the launcher, verified/optimized using the launcher.  Perused some of the forum for issues like this one but didn't find anything similar to this.

If anyone has any solutions I can try or has experienced this same issue. please reply. Thanks in advance.

Share this post


Link to post
Share on other sites

Changed Warframe to run in borderless windowed mode, now it no longer has these FPS drops.  Uncertain as to how that fixed it, but willing to smile happily and take this as a easy solution.

If anyone else has a problem like this, try what I did.

Share this post


Link to post
Share on other sites

Thanks this fixed a problem ive been having for the last 3 weeks or so. I thought maybe my vid card was about to die because I used to run WF with max video settings then all the sudden I started getting FPS drops but also my video motion would stutter even while FPS stayed around 60.  Was really making me motion sick and was worse in certain areas like earth but could happen in others too.  I had to lower my vid settings to lowest possible and I would still get motion stutters when I was running around. 

Your windowed borderless mode seems to have stopped the stutters. I will test it more this weekend by setting my graphic settings high again.

 

thanks

Share this post


Link to post
Share on other sites
On 3/9/2018 at 2:23 PM, RugerMK1 said:

Changed Warframe to run in borderless windowed mode, now it no longer has these FPS drops.  Uncertain as to how that fixed it, but willing to smile happily and take this as a easy solution.

If anyone else has a problem like this, try what I did.

So far this has been working for me even at max graphic settings.  thanks again for the find. you pretty much saved the game for me!

Share this post


Link to post
Share on other sites

Can you tell us how you ran the game before you came across this borderless windowed solution? Was it fullscreen or windowed? Curious if there is something that we can do on our end to find the culprit. Thanks!

Share this post


Link to post
Share on other sites
12 hours ago, [DE]Dmitri said:

Can you tell us how you ran the game before you came across this borderless windowed solution? Was it fullscreen or windowed? Curious if there is something that we can do on our end to find the culprit. Thanks!

I was running fullscreen with most settings on highest before I ran into these performance issues.  Ill try to go into more detail later when i get the time.

thanks for looking into this!

I'm using 760gtx with 1gb vid mem

16gb system ram on i7

 

Share this post


Link to post
Share on other sites

I have:

i5-6600

2x4gb(8gb) 2133hz ddr4 kingstone ram

gtx 1050 ti

I have to upgraded my ram to 12gb to solve the entire frame drops in the game for me.

Share this post


Link to post
Share on other sites

I'm using a much lower end PC than You guys and borderless window also gives me way better performance also. Basicaly the only performance issues I have are crowded relays. Full screen eats away all my RAM after a while, too.

i5-2500, 8GB RAM, Sapphire HD 6850 1GB

Share this post


Link to post
Share on other sites

Do you guys still suffer FPS dips in crowded encounters in 4 man squads with borderless ?

 

Normally the game runs fine, but when things get crowded I suffer massive fps dips, from 200 to 90's. Especially when I'm the host.

 

 

Share this post


Link to post
Share on other sites

Wow didn't realize my topic had garnered more attention.  I ran the game in Fullscreen mode before with max settings.

Using an i7-6700k 16GB RAM and a Zotec Nvidia GTX 970 with February's Nvidia drivers.

Also I was under the impression that running in a windowed or borderless windowed mode actually took MORE system resources to operate than full screen.

And I really had NO idea what settings to try to tweak to fix it, I just selected borderless windowed mode on a whim.  Even a blind squirrel finds a nut occasionally!

Edit: Tested Warframe in Cetus/Plains now in both fullscreen and borderless windowed mode, they're both fine with no FPS drops now. Perhaps an undocumented patch change or other fix has resolved this issue, at least in my situation.

Share this post


Link to post
Share on other sites

I used to have very big slowdowns in the relays during baro times and in cetus but the windowed borderless mode has made that much better for me as well.  Still slower but nowhere near as bad as it used to be.

Share this post


Link to post
Share on other sites
On 3/5/2018 at 2:20 AM, RugerMK1 said:

Running a Nvidia GTX 970, on the ship my FPS are fine but in the Orokin Void tileset or the Plains/Cetus I get severe FPS drops. FPS goes from holding at 70 to 30s in the Void, in the Plains the drop is even worse down to 18FPS.  I was getting this FPS drop with older Nvidia drivers from Nov/Dec/Jan before updating to February's drivers which did not resolve the issue.

Oddly enough, I am able to play on the Kuva Fortress tileset just fine. 70 FPS during a testing mobile defense.  I  tried turning off DirectX 10 in the launcher, verified/optimized using the launcher.  Perused some of the forum for issues like this one but didn't find anything similar to this.

If anyone has any solutions I can try or has experienced this same issue. please reply. Thanks in advance.

In the Warframe launcher, deselect DX11 under the settings cogwheel in the upper right. Make sure only DX10 is selected. This fixed the recent performance drops with the March 15th patch for me and some others. Thanks to Happy2B for finding this fix!

Share this post


Link to post
Share on other sites