Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Venus - Venera, Game Broke Entirely


Recommended Posts

I believe we're at 9.5.1, I just finished playing this mission and it was a bit laggy (possibly the initial cause for the issue) and the following happened:


-Mission Failed (we lost, fair and square)

-Experience points added up on screen, didn't get any drops (all normal here too)

-Game did not end, I was left to run around the level where my teammates (who I'm sure were actually gone) and enemies stood still

-Tried to Abort Mission, was not allowed to, an error message said I could not abort because the mission already failed

-Tried to Quit Game, clicking this made the menu flash once and did nothing else

-Alt+F4 to end game, this worked


For someone who isn't aware of using Alt+F4, they may very well have turned off their computer to resolve the issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...