Jump to content
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

What Happend To The Founders Package?


Recommended Posts

it was bugged Friday as well, came up a few hours later.

I was trying to buy the hunter pack, but kept getting "no params for 1220" error pop-up box when clicking buy now.


I tried all the packs, 3 different browsers and 3 different computers, 2 of them from different locations.


I wouldn't worry OP, they will come back up soon.


If you just want plat now, try the regular plat packs, I'm sure they will work for you.

Link to comment
Share on other sites

I upgraded mine from basic to second tier 2 hours ago. worked fine for me at least. Btw, my profile still doesn't recognize the update.

I think.

EDIT: Oh wait, it's there :P kudos.

eh? you could upgrade founders?

how does it works?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...