Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Consumables Menu Not Showing Up.


Recommended Posts

Starting this for a friend.  She has put in a ticket, but still would like to know if others have been having a similar issue.


Lately whenever she joins a match or even hosts one, she can't pull up her items menus so she can refill her ammo, heal, etc.   Sometimes it right from the start the menu doesn't come up, other times its about a minute or so into the mission and it stops coming up, even the player window at times glitches and doesn't come up so she can watch health since she plays the trinity the most.   


Its getting to the point that its frustrating for her to play the game, cause she runs with the braton and the twin faris, so runs out of ammo fast.  


She's tried using steam to verify the files, and had several that needed to be redownloaded and that didn't fix it, think she even reinstalled completely and still no fix.  Changing the key doesn't seem to work either for a fix, that lasts more then a few seconds.


I do hope this can be looked into.



Link to comment
Share on other sites

Had the same problem for around 3 months. Told them, asked them and wasted my breathe time after time. I doubt anyone will answer or care as it only affects a small minority. Bullets/projectiles also vanish and do not appear on the right hand side of the screen (press H). This is another chestnut they chose to ignore.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...