Jump to content
Temporary sub-forum for Update 30: Call of the Tempestarii ×
  • 1

Stuck in Excavation - What do I do?


Go to solution Solved by Salenstormwing,

Question

As the Title says Im currently stuck in a Excavation mission( a void mission to be exact) and the prompt for me to leave hasnt shown up yet I already went trough 4 or 5 relics and I have lots of loot but I want to leave I read that I have to get an excavator to 100% but that is impossible since no enemies with power cells are spawning.

also ive been playing for so long that I can only kill enemies when im out of their range

 

someone please help me

Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Follow the Green blob. Are you the host? The host might have a bad connection or something? It sounds like a glitch happened if you can't see the evac location.

 

Are you the only person there or others? Ask others to go to the exit with you, you have to leave as a group if you're in a group.

Link to post
Share on other sites
  • 0
3 minutes ago, Salenstormwing said:

Follow the Green blob. Are you the host? The host might have a bad connection or something? It sounds like a glitch happened if you can't see the evac location.

 

Are you the only person there or others? Ask others to go to the exit with you, you have to leave as a group if you're in a group.

there is no green blob and im playing solo I already found the "exit" but since there is no green blob I cant leave

Link to post
Share on other sites
  • 0
10 minutes ago, Kannzo said:

someone please help me

In the excavation missions green extraction indicator on the minimap is often obstructed by the yellow excavator indicators. Most probably this is the problem in your case. Open a map (M by default) or follow the yellow one first and then go to extraction.

Link to post
Share on other sites
  • 0
4 minutes ago, manimalia said:

In the excavation missions green extraction indicator on the minimap is often obstructed by the yellow excavator indicators. Most probably this is the problem in your case. Open a map (M by default) or follow the yellow one first and then go to extraction.

I agree with what this person wrote. Follow the yellow until you find the green.

Link to post
Share on other sites
  • 0
6 minutes ago, (XB1)Thang Hung said:

I agree with what this person wrote. Follow the yellow until you find the green.

didnt work 

I already mentioned that I already found the "exit" and I went there but nothing happened 

the "big map" (pressing M) reset but nothing else after being overrun 2 times waiting there I just aborted

Link to post
Share on other sites
  • 0
Just now, Kannzo said:

didnt work 

I already mentioned that I already found the "exit" and I went there but nothing happened 

the "big map" (pressing M) reset but nothing else after being overrun 2 times waiting there I just aborted

Man that bites hard. Sounded like you had good loot haul too. Sorry to hear you didn't make it out.

Link to post
Share on other sites
  • 0
8 minutes ago, (XB1)Thang Hung said:

Man that bites hard. Sounded like you had good loot haul too. Sorry to hear you didn't make it out.

I had a forma blueprint which is what I wanted I also got a cernos prime blueprint some paris prime parts and a lex prime barrel

Link to post
Share on other sites
  • 0

This is a common problem with excavations, at least the one on Pluto - when I finish my first one I always make sure to look at the green waypoint on the big map before starting the 2nd excavator, because as sure as shooting it will not show after the 2nd excavator - I always extract after 2 for best Endo chances. Like others have said, the green is actually under a yellow, so heading towards the next extraction will reveal it again. This IS something that needs to be fixed, but that is what you need to know.

G'luck!

@DocAgony- you psyched me dude, this conversation is from April, I answered your recent post to it. - well maybe it will help somebody (egg-myface)

Edited by Canach
Link to post
Share on other sites
  • 0

Same exact thing happened to me. But i think my game bugged. After i would complete an excavation site, it would just keep giving me more. it would not stop. i ended up doing around 7-8 excavation sites and i had no choice but to abort. This really made me unhappy as i got a lot of good loot. Also, the green marker pointing to the end would just appear at the very edge, not even on the map area. FIX THIS GODDAMNIT

 

Link to post
Share on other sites
  • 0

I'm supporting this necro because it's been two years and it hasn't been fixed yet.

Green exit icon is very moody. They're most useful when appear on hud AND minimap, exactly on top of the door you should take. But sometimes they'll just entirely gone from the hud, and positions itself somewhere out of bounds on the minimap. This is huge problem when you play on unfamiliar maps.

Also.. yeah, the arrived at the exit but I'm not getting extracted which probably can be considered as one of warframe's staple at this point.

Edited by Soy77
Link to post
Share on other sites
  • 0
On 2021-01-18 at 5:24 AM, Lutesque said:

So this mission is still Broken I see...😐

i'll be lucky if it's just this mission

i had exit doesn't work on archwing missions, opening relics, orphix venom... it's ridiculous.

Link to post
Share on other sites
  • 0
On 2018-04-04 at 5:11 PM, Salenstormwing said:

Abort then. Sounds like the mission is bugged.

Never abort mission if you already completed it. It will reset everything you achieved, looted etc.

Always ALT+f4. This lets you keep your looted stuff/exp/end wave prizes most of the time. Only thing you do not get is mission completion credit and prize (because you havent).

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...