Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Cant Join Clan


Recommended Posts

When the dojo keys first game out I got one and made it thinking I would have my own dojo, I don't but no biggie.  However, now it seems that having the key is blocking me from joining a clan.  Iv tried to join 2 so far and both ppl say they are getting a message saying I am currently in a clan.  My clan window is blank and I have not joined one.  So I THINK it has something to do with having a key but not having a clan.  So, my question is, how do I delete the key? I already tried under arsenal/inventory but keys are not listed there and there is no delete option under the keys.

is this a bug anyone knows about IF it even has anything to do with the key itself?


Link to comment
Share on other sites

You appear to have another pending clan invite (you can only have one at a time). It shows up on your clan window; you can right click it to accept or decline the invitation.

Wow, just complementing you on your awesome avatar, haven't seen you around much before!


And yes, it does appear that you already have an invite pending.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...