Jump to content
General Bug Report Guidelines - Please Read ×
Echoes of Duviri: Share Bug Reports and Feedback Here! ×

Constant - 6 Health Per Second And No Shields


Recommended Posts

Ok this has happened a few times for me in the past no big deal but now it happens every time i start a mission.

I will either start the mission and be losing 6 hit points per second and get insta killed when engaging in combat or start the level with 0 shields.


Idk what the deal is but this happened 5 times in a row for me today. Any thoughts or ideas how to fix? I've relaunched and aborted and still the same thing.


BTW this happened on the Vay Hek assassination level 5 times in a row. Usually on other levels in the past I just abort and relaunch the patcher and it has worked, but not this time.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...