Archived

This topic is now archived and is closed to further replies.

halobattlefront

20 fps max on nvidia gtx graphics card

Recommended Posts

Hi so I've been plagued by fps problems as of late on warframe. I stopped playing 4 years ago and I wanted to get back into it. In these 4 years I also got a new gaming laptop here are the specs:

laptop: Lenovo y700

6th Generation Intel® Core™ i7-6700HQ Processor (2.60GHz 6MB)

NVIDIA® GeForce® GTX 960M 4GB

8 GB RAM

1TB 5400 RPM

These past couple of days I've been stuck at 20 fps and today I just couldn't stand it anymore. Normally I should be getting high 100 fps but in the orbiter I only get a consistent 20 fps max. In comparison my brothers laptop which has a gtx 940mx (which is worse than mine) has 70 fps while in the orbiter. I tried doing optimizations, double checked that my laptop was running the nvidia card (and it is), and updated my graphics drivers. Nothing changed, still 20 fps. 

If anyone knows a solution to my problems that would be tremendous because at this rate I'm feeling like not getting back into this after all.

Share this post


Link to post
Share on other sites

Are you using Windows 10's latest update (Spring Creators)? That should allow you to change Warframe's performance mode so it uses the high end GPU, because it sounds it's using the integrated/low end GPU instead.

Share this post


Link to post
Share on other sites
8 hours ago, NightmareT12 said:

Are you using Windows 10's latest update (Spring Creators)? That should allow you to change Warframe's performance mode so it uses the high end GPU, because it sounds it's using the integrated/low end GPU instead.

Where would we go about doing that? That sounds like a logical reason since that update just dropped, but I'm not sure where that choice would be hiding.

Share this post


Link to post
Share on other sites
5 minutes ago, Fluffysbeans said:

Where would we go about doing that? That sounds like a logical reason since that update just dropped, but I'm not sure where that choice would be hiding.

Sorry I did not post it earlier 😛

There's two things: First one is the whole System Energy/Power plan (not sure of the english name), which you can go through "Settings" (the cogwheel when you click Windows button) -> "System" -> "Power/Sleep" -> "Additional Settings" on the right panel of the window.

And then you can nset each application individually by going through "Settings" -> "System" -> "Graphic Settings" (it's the bottom/last option, right below advanced display). There you set it to "classic" from the drop down and then go find the EXE file through your folders, once added click on it on the list and you'll be able to change it to High Performance.

Hope this helps! 🙂

Share this post


Link to post
Share on other sites

Tried what you suggested, optimized download cache, verified, tried setting to low, tried changing v-synch, basically ran through the whole shebang, and my game is still fluctuating between flat 30 or 60. Each time it jumps between the two, it has a visible pause.

My guess would still be that it's related to the windows 1803 update since DE hasn't done any patches and that would be the only thing that changed. It's odd though that other 3D games are running at perfect 60, I would figure that a windows update borking one game so severely would hit at least a few others.

Share this post


Link to post
Share on other sites
23 minutes ago, Fluffysbeans said:

Tried what you suggested, optimized download cache, verified, tried setting to low, tried changing v-synch, basically ran through the whole shebang, and my game is still fluctuating between flat 30 or 60. Each time it jumps between the two, it has a visible pause.

My guess would still be that it's related to the windows 1803 update since DE hasn't done any patches and that would be the only thing that changed. It's odd though that other 3D games are running at perfect 60, I would figure that a windows update borking one game so severely would hit at least a few others.

There have been claims that the Focus Assist setting that was recently introduced to Windows 10 could have an impact on performance. Have you tried toggling that?

  1. Open Settings.
  2. Click on System.
  3. Click on Focus assist.
  4. Select "Off"

Also, you'll want to make sure that the Power Management mode in your Nvidia Control Panel is set to "Prefer maximum performance".

NvidiaPower011.png.390d39264d4f88a9ca1c1312d143634f.png

Share this post


Link to post
Share on other sites

@NightmareT12 that did the trick! The windows update took several hours to download and install but my warframe is running cleanly now with 200 fps thanks a ton!

Also thanks to everyone else who tried to help!

Share this post


Link to post
Share on other sites

Focus assist was already off, although the automatic rule section had it ticked on for games. I tried it with that setting both on and off, but no fps change.
Same deal with power management, I was already on maximum.

Share this post


Link to post
Share on other sites

I ended up rolling my windows update back to the version before the april 2018 update, and warframe is back to normal.

Share this post


Link to post
Share on other sites
22 hours ago, halobattlefront said:

@NightmareT12 that did the trick! The windows update took several hours to download and install but my warframe is running cleanly now with 200 fps thanks a ton!

Also thanks to everyone else who tried to help!

Glad to hear! 🙂

 

16 hours ago, Fluffysbeans said:

I ended up rolling my windows update back to the version before the april 2018 update, and warframe is back to normal.

Weird, on my end Windows has caused no issues (In fact it's fixed several issues I had). I know for experience that sometimes Windows bugs itself updating and a clean install takes away some issues (I remember some new features never appearing on the initial Creators Update and being fixed when I reinstalled it lol).

Oh well, hopefully a future Windows update brings it back to normal and you can catch up later 🙂

Share this post


Link to post
Share on other sites