• 0
Kidroll

Can't rank-up Pilfering Swarm

Question

Posted (edited)

Hello,

So, I just made enough rank and syndicate standing to buy Pilfering Swarm mod.
I equipped it and when I click on "Mods" to rank it up I don't have my equipped mods listed as I usually do, I have everything else instead! Pilfering Swarm is not there even if I search for it.
I tried unequipping it and clicking on Mods again, and again, I have everything listed and Pilfering Swarm mod is nowhere to be found.
Under the "Installed" category/section in this screen I have zero mods, even though I have Pilfering Swarm at rank 0 of 3.

Has anyone else ran into this? How can I rank up mods?
This is only on Hydroid. Other warframes don't have this behavior and I can see only the equipped mods to rank up.

Edited by Kidroll

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Very odd, I haven't experienced this yet! I will try to give a look-see as soon as I can. If it does persist, try to see if you can create a support ticket with screen shots, it might be able to help support identify the issue and if its a glitch, fix it asap.

Share this post


Link to post
Share on other sites
  • 0

Did you try to restart your game? Fixes almost every WF-feature

  • Applause 1

Share this post


Link to post
Share on other sites
  • 0

Have you filtered your mod list to show only certain types of mods?

  • Applause 1
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
36 minutes ago, Kidroll said:

I restarted. and I reset filters as well. Still can't see it.

This is the image with my mods equipped.

This is what I see when I click on Mods.

I bought a second one. So I have one equipped, and one unequipped. I can't find it at all, when I click mods through Arsenal or when I search for it in the Mods module...

Try to change: "Sort by:" bar from "recent" into something else. 

Share this post


Link to post
Share on other sites
  • 0
43 minutes ago, Kidroll said:

I restarted. and I reset filters as well. Still can't see it.

This is the image with my mods equipped.

This is what I see when I click on Mods.

I bought a second one. So I have one equipped, and one unequipped. I can't find it at all, when I click mods through Arsenal or when I search for it in the Mods module...

Looks like your list is filtered to only show common mods.

  • Like 2
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Naftal said:

Looks like your list is filtered to only show common mods.

OMG, that was indeed it.... I'm so dumb. Thanks a lot man!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now