Jump to content

Elemental Weapon FX showing up on some melee weapons - even when FX are turned off.


MirageKnight

Recommended Posts

As it says on the tin. This bug has been around for at least several months (probably longer), been reported repeatedly, and applies to the following weapons:

  • Gunsen
  • All Nikanas - including Umbra Excalibur's Skiajati (will show through the scabbard)
  • Venka Prime
  • Sigma and Octantis (only shows in mission and will temporarily disappear at random)
  • Glaive Prime
  • Orvius

20C7785FFA5A6AEDE9785AD9FA21572AF78340A9

A0F17FADC7AECD0D87E189D137C997958451E24B

9B8F009DC2AA50A964D5D875448EE8236C275F04

 

There are possibly a few other weapons, but these are ones that I have seen so far. If anyone has seen this on any other weapons, reply to this post and I'll add them to the list.

More than likely this affects consoles as well.

This bug is fairly easy to replicate. Simple turn off Elemental Weapon FX under options, equip any of these weapons (don't just preview them) in the arsenal and mod them for any type of elemental damage. Elemental FX will show up on the blade in mission and in the arsenal (with one noted exception).

Fixes for this have been requested for some time in numerous update feedback threads to no avail.

It would be GREATLY appreciated if this could be fixed soon. If you can address size scaling issues with weapon skins within a day or two, this should be really easy to fix.

Thanks for reading!

Link to post
Share on other sites

Ugh. Ancient, horrific bug. "Literally unplayable."

Viral on Dragon Nikana

Z6I7Qtv.jpg

Radiation on Gunsen

0flYSdA.jpg

Viral + Radiation on Venka (Stuff like this is why I have these FX turned off.)

6vb1KUD.jpg

Fire on Orvius

Yl4Oemj.jpg

Blech. Is it hard to fix this? Countless other equally minor issues have been addressed pretty quickly... Even if it's "sorry guys we have no idea what is causing this," it'd be nice to know that the devs are at least aware of this issue.

Link to post
Share on other sites
18 hours ago, DYSEQTA said:

Seems odd to do just do one out of a group with similar issues >.<

Except FX still persist on the blade itself so the core problem still remains. The sheath just hides any FX now.

Link to post
Share on other sites
  • 3 weeks later...
  • 3 weeks later...
  • 2 weeks later...
On 2018-07-01 at 4:32 PM, (XB1)KrombopulosTunt said:

Is this player specific or something because I imagined more would be complaining about this bug if it were for everyone.

Oh this affects everyone, regardless of platform it seems. And a number of threads on the topic exist...this one below highlights them all.

 

Link to post
Share on other sites

Simple, DE doesn't seem to care about "minor" issues like this.

Oh they care when some player with a high reputation whines at length about a new weapon that's slightly oversized and they'll fix that travesty within two hotfixes......but things like this? Not worth their precious time and effort to respond to, let alone fix.

Because what "true" Warframe player would turn off elemental fx on blades anyway? I'll give you a hint: They'd be the ones that think elemental FX on blades are an eyesore when it comes to their Fashion Frame.

That brings me to an important point: Fashion-frame is a big deal for us, and the devs know it...they even cater to it. Which makes an oversight like this even more baffling.

Link to post
Share on other sites

Seems like such an easy fix and with the amount of threads about it it should have been dealt with a LONG time ago.

I even tried posting about this on reddit, since that's where the devs seem to lurk more, but it got maybe 3 upvotes and 0 replies. I need this to be fixed it's such a bothersome issue.

Link to post
Share on other sites
53 minutes ago, (XB1)KrombopulosTunt said:

Guys don't mouth off about DE, its just a minor bug, and while annoying, its not exactly game breaking. I have faith that they'll patch it, we just have to get these threads seen by them. They're better than other devs when it comes to this sort of stuff anyway.

Oh right sure let's just praise them for not fixing this bug for almost 10 months.

Link to post
Share on other sites
2 hours ago, (XB1)KrombopulosTunt said:

Guys don't mouth off about DE

First of all, white knight / back-seat moderator much? That's really frowned on here.

Second, posting a legit complaint about a long term issue that's been effectively ignored is NOT "mouthing off" as you so inaccurately and fallaciously put it.

2 hours ago, (XB1)KrombopulosTunt said:

we just have to get these threads seen by them.

You think we've just been sitting on our butts about this for so long about this? This bug has been around for at least 10 months and numerous people have complained about it. At length and in various threads and posts. Yet it still persists and it's even showing up in new weapons. See the Skiajati: It has the exact same visual issues as every other Nikana.

I also feel the need to point out that this is just one of at least several dozen "minor bugs"  that DE have failed to address that people have repeatedly reminded them about...bugs which DE has failed to even publicly acknowledge so far.

2 hours ago, (XB1)KrombopulosTunt said:

They're better than other devs when it comes to this sort of stuff anyway

Sorry, but this lame excuse has been used to defend DE from legitimate criticism before and it still falls completely flat. That being said, It can be counter-argued that there are better devs than DE that would never let even "minor" issues like this persist for long.

I'd also like to point out that If DE can fix a weapon as graphically bugged as the Hystrix was on release within a couple of days...

...they should be able to sort a bug like this out fairly quickly.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...