Jump to content
[DE]Megan

The Sacrifice: Hotfix 23.0.1

Recommended Posts

Hotfix at your 1:30 AM!!  Thanks for your hard work and dedication!!  :community:

  • Like 1

Share this post


Link to post
Share on other sites

wheres the "we gave you more polarities on your exalted weapons because we gave you not nearly enough to use any of them without 3+ extra forma" 

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites

Thank you a lot, but please some forma? I have like 4 exalted blades and 3 others to forma. Also I have to restore my statstick weapons to viable builds.

  • Upvote 1

Share this post


Link to post
Share on other sites

All of the DE Devs worked extremely fast to get this hotfix out and I say thank you from the bottom of my heart. This game has been with me for years now and I enjoyed every minute of it. Thanks for making the final trilogy so epic!!

  • Like 2

Share this post


Link to post
Share on other sites

Hey guys...got me Exca Umbra, nice frame, BUT...is it the way, it should be, that Magus Nourish (Operator Arcane) wont take effect on Umbra? 

BTW...the mod Physique has never ever taken any effect on any frame...bug, or feature!? :D

Share this post


Link to post
Share on other sites
Spoiler

So, when will we be able to use forma to add umbra slots to things? Also, what happens if somebody erases the existing umbra slots. And lastly, is this the beginning of a class of umbral warframe variants in the future?

Also, great job on fixing the forum crash so quickly!!!

Edited by Hexeract
  • Upvote 1

Share this post


Link to post
Share on other sites

I offer my thanks for both a quick hotfix and quest. 

Share this post


Link to post
Share on other sites

After 5 hours or so, I have finally finished updating!

Had to uninstall and reinstall after 2 hours or so updating to make it work.

But now I have to go out for an appointment.

What lousy luck😣

FML

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for fix and content update DE but please fix the launcher, every +500MB update was a pain for me, it start to download then it's 100% in an instant with an error at the end. it hurts alot when the download speed can bearly go over 100kb/s for some reason. (other downloads are fine, at 70MB/s downloaded the same 2GB update for Path of Exile while waiting and watching WF fail to update at 40kb/s with errors - still 1.2GB to go 100s of other Update failed to deal with)

Edited by AmirBan

Share this post


Link to post
Share on other sites

Thanks for the quick fix, DE! Though I've noticed Exalibur Umbra's exalted blade plays the animation for radial blind on slide attack like the rest of the Excalibur 'dialect' , but doesn't actually cast --  using energy. Hopefully this can be fixed soon, perhaps by removing the radial blind on slide entirely for Umbra? Thanks.

  • Upvote 1

Share this post


Link to post
Share on other sites

long story short, my launcher is downloading in the single digit KB/s speed, and I have a high-speed connection...  been downloading for 4hours.

if at the end of this long wait and long slow download it is broken, just like my clan members keep reporting on discord,  i will not be a happy camper.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you for the fix and hard work DE. Get some sleep though! You guys deserve it! ^^

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...