Jump to content

Archived

This topic is now archived and is closed to further replies.

Artekkor

Ordis gave me Excalibur Umbra animations sets. But... I had them already?

Recommended Posts

Excalibur Umbra has unique Noble and Agility idle animation sets that i could use right away.

However, some time after the quest, Ordis sent me a message of gits which also included Umbra's animation sets... But they do not appear for any other warframe but Umbra. Where i had them before anyway.

Was that a bug? Did i shomehow did not received those animations sets to be used on my other warframes, or was that some plan-B safe-switch to make sure players actually receive the animations for Umbra himself?

Share this post


Link to post
Share on other sites
12 минут назад, Koldraxon-732 сказал:

Likely the Plan B 'safe switch' was why you got the message with the contents.

Well, still could be possibly just a bug... Hopefully.

I really would love to use Umbra Noble on my Rhino. Its such a good animation set. The only one that holds pistols properly.

Share this post


Link to post
Share on other sites

Probably made it accessible to other frames or something. Adding/replacing items would fix whatever the originals may have had issues with.

Share this post


Link to post
Share on other sites
Только что, direcyphre сказал:

Probably made it accessible to other frames or something. Adding/replacing items would fix whatever the originals may have had issues with.

Except it didn't. Not even to normal Excalibur.

Share this post


Link to post
Share on other sites

I thought i had the same problem. Try this, unequip the animation from excalibur umbra, then try to equip it to another warframe, you ll see that now u can equip excalibur umbra animation to all warframes 😄

 

Share this post


Link to post
Share on other sites
5 часов назад, Migan101 сказал:

I thought i had the same problem. Try this, unequip the animation from excalibur umbra, then try to equip it to another warframe, you ll see that now u can equip excalibur umbra animation to all warframes 😄

 

Actually, that's because they fixed it with Prime Acess update.
Apparently it was a bug indeed.

Share this post


Link to post
Share on other sites

×
×
  • Create New...