Efreeti

(PC) WASD and arrow keys moving cursor? Can't be disabled?

Recommended Posts

Posted (edited)

I feel like I'm the only one I know who plays Warframe for whom this is an issue. I have a controller but I never use it for Warframe. I have always and will always use keyboard and mouse. However, since the new update relating to D-Pads/cursor control for controller users, whenever I press WASD in the UI when there's a cursor present, even when just to type something in a search field, the cursor moves around to different UI elements. This is just beyond annoying and I hope this will be made possible to disable in the settings.

Edited by Efreeti
  • Like 1
  • Upvote 19

Share this post


Link to post
Share on other sites

I have the same issue, have been scanning the settings for hours to fix this but can't seem to disable this.. 

(Additionally on my own situation, I do not own a controller, nor have I ever plugged one in, already felt like the game was optimizing itself as if it was a controller game..)

  • Upvote 3

Share this post


Link to post
Share on other sites

This is their attempt at unifying the UI and allowing for snapping to targets for controller users.

I'd prefer the option to have the legacy navigation for keyboards as was before with the ability to reduce the time of animation between item transitions or eliminate it entirely.

  • Upvote 2

Share this post


Link to post
Share on other sites
Posted (edited)

yeh im not enjoying this 'feature'... if i plug in a controller. sure.. but when its only a keyboard, and i have a mouse plugged in, i dont want this. it feels like an unfinished forced controller support without a switch to turn it off even without ever using a controller. and thats kinda dumb :S

Edited by CrackCook
  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites

I too find this exceedingly annoying and desire an option to turn it off. My keyboard has Cherry mx red switches to just the slightest amount of pressure screws with my cursor.

  • Like 1
  • Upvote 3

Share this post


Link to post
Share on other sites

I'm having an issue where I'm not even in a menu and It wont let me move but instead moves my mose to the squad bar

  • Upvote 2

Share this post


Link to post
Share on other sites

I still haven't heard any aknowledgement from DE about this problem. It would be such an easy fix, as far as I can tell; just introduce an option to disable/enable controller completely, at least if disabling that option would disable WASD controlling cursor on menus too. This issue is such a pain and bothers me daily now.

  • Upvote 1

Share this post


Link to post
Share on other sites

can't press escape. had to restart the game. very annoying indeed.

  • Upvote 1

Share this post


Link to post
Share on other sites

Wow, no reply to this topic by DE yet? I randomly encountered this issue for the first time today and I have no clue why it activated. I simply finished a mission and when I got out I found that I couldn't walk around my orbiter because my keyboard wouldn't do anything besides moving the cursor to the squad bar.

  • Upvote 2

Share this post


Link to post
Share on other sites

Even with using a controller, this is still is an awkward and unintuitive "feature".

 

This absolutely needs a way to be disabled.

  • Upvote 2

Share this post


Link to post
Share on other sites

This has been  frustrating me a lot, let us disable this for the love of god. I got to a point I thought my mouse was broken or something. If I'm not using a controller why the heck would I press W and have my cursor snap to some UI element. Sorry for the rant but this makes me angry at the current controls.. I aknowledge there needs to be controller support for players that like playing with controllers, but that doesn't mean keyboard users must get hit in the face with it.

  • Upvote 2

Share this post


Link to post
Share on other sites

Add to this the problem that the cursor moves slowly when you are in any menu as if it was controlled by a gamepad instead of a mouse, it moves weird too, it makes everything painfully slow, specially when you are trying to manage mods for selling, it's like it is moving underwater and it automatically moves to places you don't want it to go, like the selection numbers box. Please, fix this as soon as possible or add an option to turn off completely the gamepad "assist".

  • Upvote 2

Share this post


Link to post
Share on other sites

Thanks for replying, everyone. I just hope DE will take note of this horrible UI decision and at least add an option to disable it.

  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, Efreeti said:

Thanks for replying, everyone. I just hope DE will take note of this horrible UI decision and at least add an option to disable it.

Have you see those console casuls? All of them play on filthy pads on the streams. There are rumors that the game is made using pads as well. Not a single k/m in DE office. The keyboard you see on the stream is a fake.

  • Upvote 2

Share this post


Link to post
Share on other sites
Posted (edited)
On 2018-08-03 at 7:54 PM, sati44 said:

Have you see those console casuls? All of them play on filthy pads on the streams. There are rumors that the game is made using pads as well. Not a single k/m in DE office. The keyboard you see on the stream is a fake.

Would be grand if you took it more seriously, as TBH I don't want insults towards DE because of this.

Edited by Efreeti
  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

This annoys the hell out of me. I impulsively tap keys, it's not something I can change, and because of it my cursor goes all over the place. Also, when there are popups like selecting a certain amount of something, the cursor automatically snaps to the middle of the screen.

All of this needs to be disabled for KB/M users and/or made opt-out in the settings. It's extremely annoying and makes the new UI feel horrible to use.

  • Upvote 3

Share this post


Link to post
Share on other sites

And I thought I was going crazy, didn't think this was in when I played last year, please do give us an option to remove it.

It makes me feel like someone has remote access because I've lost control of my mouse every other results screen.

  • Upvote 2

Share this post


Link to post
Share on other sites

I actually really like it, but a settings toggle would definitely be a good idea for those that don't.

Share this post


Link to post
Share on other sites
On 2018-07-08 at 6:12 AM, Its_Patchi said:

I know you guys at DE is busy, but can you please take a look at this? @[DE]Aidan

Aidan left DE a couple weeks ago. Pinging him won't do anything 😕

Share this post


Link to post
Share on other sites

Well to be fair he pinged him almost two months ago. This thread, and this issue, has been around a while already.

Share this post


Link to post
Share on other sites

Yeah kind of sucks that I have to force restart my game in the middle of a match because now my WASD keys are moving my mouse and I cant move in game anymore. Nice bug DE.

Share this post


Link to post
Share on other sites

I really just wish there was at least some indication that this issue has received any attention.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now