[DE]Megan

XB1 The Sacrifice: Update 23

Recommended Posts

On 2018-07-08 at 9:39 PM, (XB1)P1nstripe said:

Xbox Live is not owned as of this post.

Not sure if I'm misunderstanding here, but how are you even able to play the game if you don't have XBLive?  I thought it was not possible to play the game at all without it?

Share this post


Link to post
Share on other sites
9 hours ago, (XB1)CynNex said:

Not sure if I'm misunderstanding here, but how are you even able to play the game if you don't have XBLive?  I thought it was not possible to play the game at all without it?

So, when booting up the game, after answering the prompt of "What user is this", it loads a screen that shows Xbox live. You can eventually reach a screen where you can press a button to continue without Xbox Live. This only works for games where Solo is possible. Since I am not running Xbox Live, I am stuck in Solo mode right now. It is still possible to play, you just can't play with other people.

Share this post


Link to post
Share on other sites
19 hours ago, (XB1)P1nstripe said:

So, when booting up the game, after answering the prompt of "What user is this", it loads a screen that shows Xbox live. You can eventually reach a screen where you can press a button to continue without Xbox Live. This only works for games where Solo is possible. Since I am not running Xbox Live, I am stuck in Solo mode right now. It is still possible to play, you just can't play with other people.

Thanks for clarifying, I had no idea that was an option. Good to know

Share this post


Link to post
Share on other sites
Posted (edited)
On ‎2018‎-‎07‎-‎05 at 11:00 AM, [DE]Megan said:

Doubled the Tower White Pigment drop chance and reduced the Pigment quantity to 5.

What is this supposed to achieve? some sort of feel good measure under the pretense that some progress can be made? increase the drop chance but REDUCE the quantity?  I hope that's not how DE gives you all "raises".  "Here, I'll pay you twice as often but half as much - don't you feel so much richer now?"

I had previously simply stopped doing Tower white because the horrendous farming, but with the combination of a drop chance booster as a login reward plus this change I figured some progress could be made.  Nope. 

45 minutes of brainless running in circles from spawn point to spawn point resulted in 30 pigments (out of 900 needed).

It is this kind of grind (actually specifically Tower White) that convinced me to NEVER purchase a doubler for farming resources as I absolutely refuse to reward DE for this. 

If the 45 minutes with a doubler had resulted in 200 pigments, or if the total required had perhaps been 90 instead of 900, I would have happily spent the plat to cut 4-8 hours of grind in half.  But to reduce a 40-90 hour grind to 20-40 hours? Of absolute boredom running around killing an infrequent and inconsequential bird that has nothing interesting? yeah eff that.

 

 

Edited by (XB1)Tucker D Dawg
  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you so much for this! The sacrifice was top class - I think I love Ballas ❤️

Also I was finally able to sell most of my mods thanks to the pop up select all function which now stays on screen to deduct a few to keep for each one. I think I sold around 16k mods for 5 million credits gg

Share this post


Link to post
Share on other sites
16 hours ago, (XB1)Hell0 HAL0 096 said:

I still have the “your network has been lost, you will return to main menu” problem and it’s is getting on my nerves.

Same here. It's been bad because I can't play the game the last couple days because of this. Keeps losing connection.

  • Upvote 1

Share this post


Link to post
Share on other sites

Only Orokin Gods can help US!

One week on this connection "vortex" and nothing, i repeat nothing from Digital Extreme to help us with "not our fault issue".

I have spent this week with [DE] Nate following is magical tips to solve the problem:

  • Tip 1: Upgrade console software at last available firmware (Console firmware update are mandatory, maybe he dont know) - PROBLEM NOT SOLVED !!!
  • Tip 2: Change DNS servers to Google DNS (🙄) - PROBLEM NOT SOLVED !!!
  • Tip 3: With a mystical inspiration he said "the problem is your modem!" and suggested to add some PC (im on Xbox One/Xbox Live) related ports to my port forwarding configuration - PROBLEM NOT SOLVED !!!
  • Tip 4: Issue still present but my ticket is marked PROBLEM SOLVED!

Really? Ok thank you for support!

 

  • Upvote 1

Share this post


Link to post
Share on other sites

@[DE]Megan

Hello, in the Xbox 101 you said to come to you with issues we're having with the update, I did PM you in the forms but I guess that's not what you meant since I haven't gotten a response, I will just paste the contents here:

Quote

Hi! You said to contact you if we are having issues with update 23.

The day before the update, I was playing with friends no issue.
After however....The moment I join a group and load into an area with them, I get disconnected due to network error.
This happens in missions, relays and dojo's if I'm in a group.
I can go to dojo and relays no problem solo, and can play missions solo no problem.

I have reset my router, cleared my cache, and even tried multiplayer on my other games. Since the issue only began after update 23, I think it is safe to say it is an issue with the update. As you might imagine it has been a frustrating few days....

ps. As a side note, I would just like to say Valkyr is my favorite frame, I actually main a Valkyr Prime Hysteria build. When I first started I used Volt and it didn't really feel right, but the moment I got my hands on Valkyr it just felt natural, I was very happy. Your frame is awesome 🙂

Now since then, I have gotten back from support. They had me do stuff like clear my Warframe cache and stuff which didn't work, and I guess they missed the part where I told them I can still play Warframe online, it's only groups I can't connect to, and Warframe is my only game I'm having issues like this in, and the issues only began after update 23 since they started having me forward ports and changing my DNS and stuff.
I have seen people in chat asking if other people are having problems connecting to groups as well so I might not be the only one with this issue, but I do know it only started after the update installed. Please look into this, it has been a while since I have plated with others, and I want to show my Umbra off.

Share this post


Link to post
Share on other sites
On 2018-07-08 at 7:39 PM, (XB1)HelSeraphim617 said:

I'm constantly getting disconnected nearly every 10 mins or so. This has only started recently. I've changed display and connection settings, reset my Wifi router and xbox but I'm still getting disconnected.

Since the chat maintenance / update, I have been having the very same issue.  I tried everything that I can, and not a single thing has helped it.  The longest I've been able to stay connected to a game is maybe 5 minutes.  It keeps updating my account information, but nothing ever changes.  I'm stuck trying to level equipment, and every time I load into any kind of game mode other than my orbiter, I lose connection to the network.

Share this post


Link to post
Share on other sites
On 2018-07-15 at 7:42 PM, (XB1)Vector Didact said:

@[DE]Megan

Hello, in the Xbox 101 you said to come to you with issues we're having with the update, I did PM you in the forms but I guess that's not what you meant since I haven't gotten a response, I will just paste the contents here:

Now since then, I have gotten back from support. They had me do stuff like clear my Warframe cache and stuff which didn't work, and I guess they missed the part where I told them I can still play Warframe online, it's only groups I can't connect to, and Warframe is my only game I'm having issues like this in, and the issues only began after update 23 since they started having me forward ports and changing my DNS and stuff.
I have seen people in chat asking if other people are having problems connecting to groups as well so I might not be the only one with this issue, but I do know it only started after the update installed. Please look into this, it has been a while since I have plated with others, and I want to show my Umbra off.

Was having the same issue. DE's "tech support" ideas were worthless. In the end, I did a factory Reset of my console 18 hours ago, I'm still reinstalling all of my games, But Warframe works now

Share this post


Link to post
Share on other sites

I been hunting the three eidalons today, I manage to capture the Tera;use and the gauntulyst and was on the hydrolyse but surprise surprise “your network connection has been lost, you will return to main menu” so all that time and I’ve got nothing from it all. Is there any ways to solve this issue? I love this game to bits but this connection problem is the ONE thing I hate at this moment.

Share this post


Link to post
Share on other sites