Jump to content
[DE]Glen

Chat Server Upgrades & Experimental IPv6 Support

Recommended Posts

if only there was a workaround of this "closed ports" problem :' |
(can't trade - invite problems)

w9qgOgDHRZi7rBuHblTJGg.png

Share this post


Link to post
Share on other sites
6 hours ago, [DE]Glen said:

but unfortunately support on the PlayStation 4 can’t happen without some SDK features from Sony

Sony are just massive $&*^s. They don't want cross-platform and they don't want ipv6.. Wow

Share this post


Link to post
Share on other sites
6 hours ago, [DE]Glen said:

IPv6 you can avoid carrier 6-to-4 NAT

Aye. I know what this is. NAT is annoying to program imo so I can understand why you've upgraded 😛

Share this post


Link to post
Share on other sites

And thanks for the update Glen. Last i heard from my isp they want to phase in IPv6 by sectors in my city. I shouldn't be too far from 'getting the switch turned on' 

Edited by Neo_182

Share this post


Link to post
Share on other sites
48 minutes ago, Neo_182 said:

This only helps if the issue is on your side. I have the same issue, but the problem is with government censorship affecting certain warframe services. It worked fine before and still works fine (I made sure that warframe can open these ports and that they are visible from outside) when I connect through VPN. I can still play game without VPN, but:

1. I can't join any group directly (via invite)

2. I can't invite anyone to my group

3. I CAN host public game (and it keeps group after game ends)

4. I CAN host joinable friend-only game (and it keeps group after game ends)

5. I can't join games via friend-list

6. The only way I can join someone's group that is not hosted by me is by game connecting me to public game and me staying in group after extracting

Edited by DemonikWarframe
  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, DemonikWarframe said:

This only helps if the issue is on your side. I have the same issue, but the problem is with government censorship affecting certain warframe services. It worked fine before and still works fine (I made sure that warframe can open these ports and that they are visible from outside) when I connect through VPN. I can still play game without VPN, but:

1. I can't join any group directly (via invite)

2. I can't invite anyone to my group

3. I CAN host public game (and it keeps group after game ends)

4. I CAN host joinable friend-only game (and it keeps group after game ends)

5. I can't join games via friend-list

6. The only way I can join someone's group that is not hosted by me is by game connecting me to public game and me staying in group after extracting

Yea. That might the case for you.

But with the little information the previous player posted there's very little we can do to help.

This is why i usually start by pointing them to that url.

Share this post


Link to post
Share on other sites
4 hours ago, DemonikWarframe said:

This only helps if the issue is on your side. I have the same issue, but the problem is with government censorship affecting certain warframe services. It worked fine before and still works fine (I made sure that warframe can open these ports and that they are visible from outside) when I connect through VPN. I can still play game without VPN, but:

1. I can't join any group directly (via invite)

2. I can't invite anyone to my group

3. I CAN host public game (and it keeps group after game ends)

4. I CAN host joinable friend-only game (and it keeps group after game ends)

5. I can't join games via friend-list

6. The only way I can join someone's group that is not hosted by me is by game connecting me to public game and me staying in group after extracting

Same here, I'm praying that the developers upgrade their matchmaking system to IPv6

Share this post


Link to post
Share on other sites

I have been suffering from error 10054 for over than 8 months now and I hope this patch will fix it for me. But I have been playing Warframe since the start and one day it just started to happen. From what I heard some people found out that if they make an alt account on the same pc with the same internet the issue does not occur to the alt account. What if it's an account based issue that affecs 1 to 20 accounts?

 

Anyways I'm going to try the new update and update you wether it worked or not.

Share this post


Link to post
Share on other sites

still get the error 10054, sadly 😕 it is barely possible to play with randoms with this issue. but great to know you guys are working on it!

Share this post


Link to post
Share on other sites
Am 19.7.2018 um 19:21 schrieb [DE]Glen:

Among other things, we hope that IPv6 will reduce periodic disconnects that some people experience (usually reported as error code 10054 when a network device between your PC and our servers drops your connection for no reason). Generally we can’t “fix the internet,” so we just reconnect when it happens -- but we’re hoping that if you’re on IPv6 you can avoid carrier 6-to-4 NAT, which may avoid the issue altogether.

If this works, I love you <3 Let's give it a try :D

Share this post


Link to post
Share on other sites
On 2018-07-19 at 8:21 PM, [DE]Glen said:

I personally don’t have IPv6 connectivity (I had to test all this with a VPN), so I’m hoping to hear from you guys who have modern ISPs to tell me how well it works. Since everything should be automatic, our goal is to turn it on by default at some point in the near future once we iron out any wrinkles you may find.

if your isp  gives you real ip (static or dynamic is not important) instead of using an overloaded nat (or port restricted), you can use a (free) tunnel broker, for example hurricane electrics to get ipv6.

Depending on the router (or its custom firmware), it can be raised on it

There is also a teredo

if you want to test yourself

Edited by A-ri

Share this post


Link to post
Share on other sites

+1 for the 10054 error here

im gonna try the IPv6 now tho.

EDIT: i forgot to mention i didnt used to have this error, but after i changed ISP it kept popping up. it was so constant it felt like i was soft banned

Edited by Eremes
forgot to add some stuff

Share this post


Link to post
Share on other sites

Good! I am happy DE is picking up the slack and starting to implement IPv6. I hope one day it will be completely implemented.

Share this post


Link to post
Share on other sites

I think this has been a very bad move.   Console users (Xbox AND PS4) are having tons of network issues and this is looking like the reason why.   They say peeps on IPv4 should not have problems connecting to v6 but guess what?  We do, and its making the game unplayable!  It sounds like Warframe should wait until most people have ISP's w/ v6 and sony/micro/nintendo adopt v6.

But seriously you mess with network settings before unvault?  Did this actually go in at beasts of Sanctuary because thats when network turned to crap.  But last few days have been horrible.

Share this post


Link to post
Share on other sites

Turned on IPv6, got into a mission and just like always error 10054 happaned in one minute. Only happens in Warframe.

Share this post


Link to post
Share on other sites
On 2018-07-21 at 1:00 PM, atzepenq said:

still get the error 10054, sadly 😕 it is barely possible to play with randoms with this issue. but great to know you guys are working on it!

Well AFAICT you aren't on IPv6 so...

Share this post


Link to post
Share on other sites
3 hours ago, Darth_Melek said:

Turned on IPv6, got into a mission and just like always error 10054 happaned in one minute. Only happens in Warframe.

It looks like you last connected with v4. Did you run the test I linked in the original pos t? (https://ipv6test.google.com/)

Share this post


Link to post
Share on other sites

Hi, there. 

I also had the error 10054, that error appeared when I changed of ISP.

Since then, I always logged out of the chat and had to type something in or open it to log back in.

Today I came across this thread and found out about the new ipv6 Chat option that was added in last week's update.

 I have activated the ipv6 option from the Chat options and for the moment it seems that this problem has been solved, because I no longer have the error of 10054 and has not disconnected me.

If I ever show up again, I'll let you know over here.

Thank you.

 

Edited by MaxSaga

Share this post


Link to post
Share on other sites

I have enabled IPv6 chat, i have an ok from the google test site for IPv6, but still get error 10054 all. the. time!

Share this post


Link to post
Share on other sites

I heard that some people found out that when making an alt account the error does not happen to them on the alt but it still happens on the old one. Even though both accounts use the exect same internet service, router and IP address. My theory is that this is some sort of a data error that happens to people for some reason where the chat server kicks them out for some reason until it realizes that they shouldn't be kicked. 

 

I'll try to test this out when I have the chance and if I'm right I'll report about it here.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...