Jump to content
General Bug Report Guidelines - Please Read ×

Mutalist Alad V stops working.


Mahna
 Share

Recommended Posts

So in light of the requirement to have every node unlocked I decided to do Mutalist Alad V, since I never pick up a group for him normally I figured it would be worth a shot right now in case anyone else needed to unlock that node.

I didn't get a group so I tossed out a specter, which worked fine as it gave Alad something to try and collar. First two runs work I get two parts, I go back in for a third run and Alad gets to close to one of those piston like pillars that move up and down on the map and he stops doing anything no animations, no damage, no nothing. Abort the Mission and try again, same thing only on the lower level near the middle. Abort try again and try again, same result only this time it is by the right corner coming into his room.

I'm not doing anything different other then changing to my Opticor in hopes of hitting him from range rather then meleeing him. I enter the room kill some spawns trigger the cut scene and then fight him, toss out a specter, then at some point he just seems to stop working.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...