Jump to content
General Bug Report Guidelines - Please Read ×

Sands of Inaros


Orkan_
 Share

Recommended Posts

I nearly completed the quest line for Sand of Inaros, until the final jar popped up. I killed my 5 juggernauts and I take the jar back to the temple thing. It gives me another jar not in the middle of the map but a different side room and has me just sitting there, no one is talking and it says just to sit in the circle. I have restarted the mission twice now, tried killing myself and nothing seems to fix the bug.

Link to comment
Share on other sites

Sands of Inaros - taking the last vessel doesn't spawn the Tomb Protector.

After fulfilling the third vessel's challenge, returning to the grave and placing the urn to open the door, the last sacred vessel appears but taking it doesn't spawn the Tomb Protector.
After taking the last urn, it disappears from the pedestral and a short sound file with ambience sound is played - but the quest hint (take the vessel) and the yellow circle on the minimap stay the same. Also the female voiceover doesn't trigger.

I restarted the mission once with the same result.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...