Jump to content
General Bug Report Guidelines - Please Read ×

Mod Fusion Bug - Losing Mods


Recommended Posts

I've tried fusioning a common melee, pressurized point with a few extra mods of the same type i had, at first the mod i tried to upgrade said that i cannot upgrade that mod because it would exceed Cronus capacity, then i've tried to upgrade the not grayed out mod again, this time it didn't prompt any message, it letted me upgrade, so i raised it until i got from 20% to 60% damage bonus, then i exited the mod screen, and proceeded to go to my arsenal to se eif i could equip it, for some reasons the mod doesn't exist anymore in my inventory, the mod is gone, if possible to recover me the mod it would be appreciated.


EDIT: It seems that logging off and back on recovered the mod.

Edited by Drakaden
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...