Jump to content

Update Failed!


Saphster
 Share

Recommended Posts

So as the title says, when i launch the game it starts with the update 918MB somthing. Goes till like 20-25% and then i get folowing msg on screen...

 

''Update Failed!

Some content updates could not be downloaded from our servers.

The update will restart shortly.''

 

So i wait a bit to see if it will begin downloading and for about 2h nothing happens. I restart the game goes back to launcher, starts updating and again same msg.

Can someone please give some advice or help out.

Thx in advance.

 

Link to comment
Share on other sites

Been sitting at the "Checking for new content" screen for the past 2 hours. no network activity, no launcher activity either. restarted a couple of times; after downloading like 40 mb of updates , it cant seem to download the content at all....

are the content servers overwhelmed? or is this a regional issue? im from SEA, if any one can corroborate.

Link to comment
Share on other sites

I'm in the same boat as all of you. I've finished downloading everything though and was asked to optimize the download. Problem is after optimizing it, it failed. Now I can't do anything. I tried all the other solutions as suggested in the forums and outside but nothing works so far. I'm thinking of keeping the launcher on until tomorrow to see if anything changes, if there's none then I guess it's time to contact support again.

Link to comment
Share on other sites

1 minute ago, Sephalys said:

content servers are having an issue at the moment according to the discord channel. someone got around it my using a vpn to NA and Asia. didnt work for everyone though.

Can you send the discord link, after all they need to a notification about it, Try to download game 2 times. It's 24 gb/1 time...... 

Link to comment
Share on other sites

  • 1 month later...

I've been having this issue since december of last year. The only workaround I've found is to either use a VPN or use my smart phone as a hotspot and use that to download the update, then switch back to my normal connection to play. No idea why it works the way it does, warframe is the only game I've ever had this kind of issue with, ever.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...